Type in the full discussion title or a part of it.
Discussion Title Created date
Trouble with printf / stdout
I'm trying to print out some information and I'd like to print it all on the same line. I have the following code: printf("%7d%7d%7d%7d\r", (Int16)sensor_delta_filters[0]....
Thursday, 23 August 2012 - 20:43
Need assistance with defining my own putch( char ) function
I'm just getting started with the AVR32. I used the ATMega series several years ago, mostly with the GCC toolchain. However, I've never used printf with GCC before but even if I...
Monday, 20 August 2012 - 21:43
CGLCD - Gen Question on Startup Code
I've done a few projects using a color graphic LCD who's controller chip was actually on the glass. This allowed me to get the start-up code directly from the manufacturer. I'm...
Sunday, 6 September 2009 - 13:06
Have to Vent about PICs
I've used AVR's for about 7 years, and I admit, some of the peripherals drove me batty the first time I tried to get them working. However, the datasheet was a great resource and...
Sunday, 10 August 2008 - 15:15
IAR Problem - C w/ Assembly
I'm trying to port some code from GCC to IAR in an attemp to free up some space. The target is an ATtiny26. The problem I'm having is a delay function that was modeled after the...
Wednesday, 25 August 2004 - 19:42
Problem Switching from Polled to Interrupt Driven UARTs
In my bootloader I poll status bits to transmit data on UART1. When I am done in the bootloader, I jump to 0x0000 and begin my main application. Almost immediately I set up my...
Wednesday, 10 March 2004 - 23:07
Bootloader Confusion - ATmega128
The Atmel datasheet says the bootloader section starts at 0xF000 on pg. 286 AVR Studio has a fuse bit to start the boot loader at 0xF000 I've seen several posts here on the site...
Tuesday, 2 March 2004 - 17:12