Type in the full discussion title or a part of it.
Discussion Title Created date
ASF 3 and FreeRTOS 9 on SAM4E
Hello, We are currently using ASF 3.35 and FreeRTOS 7.3.0 on a SAM4E. It all compiles and runs fine but I note that FreeRTOS is up to v9.0 and I would like to upgrade to take...
Monday, 20 November 2017 - 06:24
USB HID on xmega A3U - how to detect USB is unplugged
Hello I have an nice USB HID implementation humming along on an xmega128A3U and realise that I am not getting the UDC_VBUS_EVENT   Does anyone have any pointers as to...
Friday, 17 July 2015 - 02:22
Does ATXmega128A3U really run at 48MHz when using RC32M for USB clock
Hello All, I am trying to understand exactly how fast the micro is running (what is ClkCPU) when using RC32M for the USB clock  I am confused, as it appears that the...
Tuesday, 16 June 2015 - 04:11
AVR-GCC and strings in flash WITHOUT needing PSTR() Wrapper
Hello all, Is there a way to tell the compiler/linker that all strings should be stored in flash without needing to specifically wrap each with the PSTR() macro?   I know...
Tuesday, 9 June 2015 - 02:31
Which xmega to use for a new USB design
Hello All, I have been playing with the Atmel Product finder all afternoon to try to narrow down a candidate for a new design that needs a USB (Device) interface and lots of Flash...
Tuesday, 17 February 2015 - 08:35
AVRStudio 6.1 Error: Invalid memorytype 10
Hello, Has anyone seen this error when starting a debug session. (see attached image) I am using AVRS6.1sp1 and JTACGICE3 debugging a cof file (Using Imagecraft 8.10.3) FWIW this...
Monday, 17 June 2013 - 16:05
Debugging ATxmega256A3U via PDI - is it possible?
Hi All, I have inherited a project and want to use PDI to debug an xmega256A3U. (by 'debug' I mean - single step, set breakpoints, view variables) I have tried with AVRStudio4.19...
Thursday, 14 March 2013 - 15:19
JTAG ICE MK II Flexibe Plastic Cable Replacement
Hello All, My beloved JTAGICE MKII is showing signs of wear as is seems that the Flexible Flat cable, connecting the JTAG header to the ICE, is now operating intermittently. Has...
Wednesday, 14 March 2007 - 02:41
Source does not correctly line up with the executable
Hello I have problem with Studio 4.12 B452 in that is des not line up the source with the code being executed. I am using ImageCraft V7.03 on WInXPSp2 with JtagICEII and Mega128...
Thursday, 6 October 2005 - 00:25
AVRDude and ATtiny2313
Hello All, I am using AvrDude 4.3.0 but it does not appear to support programming of the Tiny2313. I looked at the sources and it seems that later versions have some sort of...
Wednesday, 21 September 2005 - 14:21
[OT] Where to find Bluetooth modules
Hello All, We are looking for a bluetooth module for short range connectivity to Pocket PCs. I thought about USB and RF but USB needs wires and RF (Nordic etc) is propriatary and...
Tuesday, 8 March 2005 - 22:06