Post Created date
Can't get the Watchdog to Interrupt on ATtiny25V
Hello,   Yeah, it looks like it ! As soon as I'm done with my current project I will try a few things to confirm the minimum code with and without the WDTON fuse.  ...
Monday, 9 December 2019 - 17:27
Can't get the Watchdog to Interrupt on ATtiny25V
HAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA I can't believe it !! It finally works !! And it was an incredibly stupid mistake !! (as usual when something works for everyone except yourself...
Saturday, 7 December 2019 - 04:53
Can't get the Watchdog to Interrupt on ATtiny25V
Thanks you two :-) Really appreciated !   But still no success ... tried all the examples in the topics you shared. It's very disconcerting. I mean, I have exactly the same...
Saturday, 7 December 2019 - 03:43
Can't get the Watchdog to Interrupt on ATtiny25V
balisong42  suggested the same thing, but it doesn't help.       In safety mode 1, whether I set WDE or not, it works the same (resets after 8 sec) and the...
Friday, 6 December 2019 - 06:58
Can't get the Watchdog to Interrupt on ATtiny25V
I tried that to :( I did rtfm, many times, everything I could find, that's how I managed to arrive to a code that "should work" despite doing this for the first time.   I...
Friday, 6 December 2019 - 04:29
Can't get the Watchdog to Interrupt on ATtiny25V
Hello ki0bk,   I'm using avr-gcc   I just installed AVR Studio 7.0.2397 and didn't change anything to the config. I'm a beginner in micro-C development :)   I tired...
Friday, 6 December 2019 - 03:41
Can't get the Watchdog to Interrupt on ATtiny25V
Hello balisong42,   Thanks for the quick answer !   I tried, no difference, it still resets.    
Friday, 6 December 2019 - 03:19
Can't get the Watchdog to Interrupt on ATtiny25V
Hello again,   I added that in my loop out of curiosity :   PORTB = (WDTCR >> 4);         _delay_ms(1000);      ...
Thursday, 5 December 2019 - 23:42