Post Created date
Illegal storage class __flash in Jumpstart ImageCraft IDE
Unfortunately the project I am working on is huge and it''s gonna take too long to port along with the debugging to go with it. 
Wednesday, 5 August 2020 - 00:40
Illegal storage class __flash in Jumpstart ImageCraft IDE
Thanks for your response guys. It turns out that in ImageCraft under the compiler options I had to untick "Treat 'Const' as __Flash (See Note 1).    I'm still having to...
Tuesday, 4 August 2020 - 23:32
For loop only works once then completely stops.
Hey thanks for this code sample. I tried it out but what is happening is that it's just looping through the m2mStub_SpiTxRx code.  Here's the sample output from my debug...
Monday, 11 May 2020 - 00:57
For loop only works once then completely stops.
That part of the problem has been solved by enabling the oscillator on the custom pcb board in the code. I have removed the line "This is causing the entire thing to crash" from...
Sunday, 10 May 2020 - 12:28
For loop only works once then completely stops.
Well if I have the watchdog enabled in the code, it will cause the MCU to reset and run through the code again until it hits the for loop the 2nd time to crash.  I have the...
Sunday, 10 May 2020 - 11:36
Stuck on BOOT_ROM_START with WINC1500 and AT32UC3C1256C MCU
I know nothing about UC3 but as no one else has responded can I at least ask what the significance of 0x1014 is in this?   (It's probably not going to help your own code...
Wednesday, 22 April 2020 - 23:11
Porting from iccavr project to Atmel studio problems with Atmega2561 8 bit MCU
Now, the kind of detail you posted in #6 is of much more interest to programmers. As far as I can see, you are doing exactly the right things in the porting changes you...
Saturday, 7 March 2020 - 02:04
Porting from iccavr project to Atmel studio problems with Atmega2561 8 bit MCU
  Why not?!   Ignoring the built-in debug features of your chip is just tying your own hands behind your back. You are crippling your own debug capabilities!   I...
Saturday, 7 March 2020 - 01:52
Porting from iccavr project to Atmel studio problems with Atmega2561 8 bit MCU
PS not sure what your videos prove. I see a 2 second video of a PCB going "beep" what is that supposed to show?? It's suppose to show the comparsion of the code builds from...
Thursday, 5 March 2020 - 22:37
Porting from iccavr project to Atmel studio problems with Atmega2561 8 bit MCU
The first question is what is driving the need to port in the first place?   What's to be gained?  Don't you already have a licensed copy of ICCAVR? I do have a...
Thursday, 5 March 2020 - 22:33
SPI implementation stuck on “while(!spi_is_tx_empty(WINC1500_SPI));”
I'm using an AT32UC1256C Microcontroller. The SPI Module is getting called in my code. Here's my debug output log from Atmel Studio below here of what's happening when I'm...
Saturday, 18 January 2020 - 08:42
Trying to compile WINC1500 Driver source code
I didn't get a say on the parts unfortunately so I'm out of luck. I really don't know where to began with getting the winc1500 working with the AT32UC1256C MCU.
Saturday, 30 November 2019 - 11:54

Pages