Post Created date
SAML21 clock configuration
Spot on. Thank you. A non-zero value for CONF_NVM_WAIT_STATE fixes it.
Wednesday, 25 December 2019 - 17:26
SAMD21 SPI
Thanks. I did figure it out. Advanced Configuration for Slave had clock phase 1 selected by default. I thought setting SPI mode to 0 in code will change it. But it wasn't the case.
Sunday, 24 November 2019 - 15:22
SAMD21 SPI
Do you see anything wrong with the way i read or slave configuration. The transmitted "0xCD" seems to be read as "9B" , "0x DD" etc.
Saturday, 23 November 2019 - 18:25
SAMD21 SPI
Thanks. I managed to get one and here is how the signals look.   I am sending a byte (0xCD) from master. MOSI shows it correctly.   Current baud rate is 9600. I also...
Saturday, 23 November 2019 - 17:01
Atmel START reconfiguration hangs on "Initialize project"
Couple of suggestions based on my experience  -> Press ALT+SHIFT+A to disable auto saving while reconfiguration  -> Try an older version of Atmel Studio ,...
Thursday, 24 October 2019 - 19:15
SAMD51 stdio redirect : Framing error
Recreating the project in Another version of Atmel studio seems to have fixed the problem. Ready to move on though i don't understand how or why it was fixed. Thanks for your help.
Monday, 21 October 2019 - 21:10
SAMD51 stdio redirect : Framing error
You mean remove usart_SYNC_enable()  or do it later. It seems to enable the SERCOM.
Monday, 21 October 2019 - 19:50
SAMD51 stdio redirect : Framing error
Thanks. I tried to recreate the project from studio with just an stdio_redirection module. This time does not seem to print anything nor there is an error.  Both SERCOM usart...
Sunday, 20 October 2019 - 21:57