Post Created date
Failing linker with new device pack, ATtiny 0-series
For reference, I think my original question is answered simply by this comment: https://www.avrfreaks.net/commen...
Monday, 16 March 2020 - 09:08
Failing linker with new device pack, ATtiny 0-series
Perhaps you could use an older device pack like I did to solve the problem? I am also working in a linux environment.
Friday, 13 March 2020 - 12:55
Failing linker with new device pack, ATtiny 0-series
Thank you guys. Then I am happy for the time being :)
Friday, 13 March 2020 - 08:09
Failing linker with new device pack, ATtiny 0-series
Strange and confusing!   Ok, going back to curtvm's answer - Thank you for pointing out that proposed change. But that file is coming from the avr-gcc toolchain package and...
Thursday, 12 March 2020 - 14:16
Failing linker with new device pack, ATtiny 0-series
curtvm wrote: I would start by getting into the 2's- https://packs.download.microchip... they have old links with old versions. you just have to poke around to find the latest....
Thursday, 12 March 2020 - 13:04
Xplained Nano mEDBG no connection
mraardvark wrote:pyupdi or one its forks? Thanks, yes, this seems as the way to do it. I put a mega328p on a proto board and tried jtag2updi ( https://github.com/ElTangas/...
Monday, 1 July 2019 - 13:48
Xplained Nano mEDBG no connection
gchapman wrote:   Hopefully Atmel Studio 7's automatic firmware update will solve that issue; latest firmware should be with Atmel Studio.       Thanks,...
Wednesday, 26 June 2019 - 13:07
Xplained Nano mEDBG no connection
Ok, I applied the patch but it didn't change anything. I also tried with build flags as suggested by the author ( https://lists.nongnu.org/archive... ) but neither that helped :(
Wednesday, 26 June 2019 - 11:29
Xplained Nano mEDBG no connection
clawson wrote: In the source tree I only see two branches, one of which is 7 years old and the other is 18 years(!) I used what is in "trunk" which seems to be 5 months old. (...
Wednesday, 26 June 2019 - 10:56
Xplained Nano mEDBG no connection
Do I have to manually apply such patches? How do I do that? Is there a branch where they already have been applied?
Wednesday, 26 June 2019 - 10:07
Xplained Nano mEDBG no connection
Continuing this thread, which was helpful to me.. It seems that libhid is hard to find. Is it necessary? Or is libhidapi enough?   When building avrdude with the latter only...
Wednesday, 26 June 2019 - 09:22
building gcc=8.3, avr-libc on Linux w/ atpack hooks
clawson wrote:PS unless you desperately need an 8 or a 9 or similar then why not simply take the most recent Atmel build .tar.gz for Linux ?   You mean from Microchip?...
Wednesday, 26 June 2019 - 06:47

Pages