Post Created date
Atmega168a RX Interrup doesnt appear to trigger
I still havent managed to get debug wire working on the ATMega. I had someone else look at the problem and we went through the code and rewrote it from scratch and still the same...
Saturday, 11 May 2019 - 11:06
Atmega168a RX Interrup doesnt appear to trigger
I tried using your code however the LED gets "stuck" after i send a char over serial.  meslomp wrote: what happens if you use this code: int main(void) { DDRD = (1<<...
Saturday, 30 March 2019 - 09:19
Atmega168a RX Interrup doesnt appear to trigger
Yes i got sparrows point, make sure the flag has been "reset" by reading from the register. that way the system is in a known state when you try to run again. I used your second...
Monday, 25 March 2019 - 15:22
Atmega168a RX Interrup doesnt appear to trigger
I have added in a read of UDR0 in the ISR and directly after sei() and still no visible response on the LED   Add: I see this : return UDR0;   This has worked when i...
Monday, 25 March 2019 - 14:55
Atmega168a RX Interrup doesnt appear to trigger
This is the zip    
Monday, 25 March 2019 - 14:30
Atmega168a RX Interrup doesnt appear to trigger
This is why ive been a little stumped at whats going on, everything says it should work but it isnt. I dont think ive done something stuipid with it, or missed anything out...
Monday, 25 March 2019 - 14:21
Atmega168a RX Interrup doesnt appear to trigger
no i dont, im using a usbasp programmer
Monday, 25 March 2019 - 14:00
Atmega168a RX Interrup doesnt appear to trigger
Thanks you for spotting that, ive added the port direction definition in and ive also added to turn the light on so i could see when the program started (code below). This still...
Monday, 25 March 2019 - 13:56
Atmega168a RX Interrup doesnt appear to trigger
I started out testing normal serial communication with the RX and TX within the main loop, i had it echoing back the characters as i typed them and they were all coming back...
Monday, 25 March 2019 - 13:38