Post Created date
Solved: atmega328p using an external oscillator
OMG.  You're absolutely right.  It says 100MHZ on the chip too (very small).  Duh!.  Packet they came is says 20MHz.  Lesson learnt, don't assume the...
Thursday, 29 August 2019 - 14:02
Solved: atmega328p using an external oscillator
scope looks ok, but I'm no expert   regards
Thursday, 29 August 2019 - 13:47
Solved: atmega328p using an external oscillator
Thanks,   Made new board with new chip.  Worked until I set clock to Ext clock, then unreachable though it is flashing a led but very slowly (blink test program I...
Wednesday, 28 August 2019 - 12:27
Solved: atmega328p using an external oscillator
Thank you.   My final question though, how does the chip know the clock is at 20Mhz? Surely there's more than simply setting F_CPU ?   regards  
Tuesday, 27 August 2019 - 20:04
CCL, LUTS and Encoders
Do you believe that is the case for all 2 pin encoders? It's been a while since I looked at the code, but some encoders send multiple pulses per detent (4) and others 2  ...
Wednesday, 21 August 2019 - 21:43
CCL, LUTS and Encoders
Mechanical concentric ones, such as Elma E37 as well as regular quad ones.  Movement is human generated, not some other mechanical device.  Are you thinking polling will...
Wednesday, 21 August 2019 - 21:21
CCL, LUTS and Encoders
Sadly the 2560 only has 24 PCINTS, but I think if I go with an external oscillator on the 324PB I'll get back a pin and should be ok.   regards    
Wednesday, 21 August 2019 - 19:44
CCL, LUTS and Encoders
I have 16 encoders working with PCINT using an ATmega324PB built with the arduino IDE.  Problem is I don't have enough spare pins if I want to convert using Studio7 and...
Wednesday, 21 August 2019 - 19:11
CCL, LUTS and Encoders
Because I need more than 2, ie 16.  My bad for not making it clear.   regards  
Wednesday, 21 August 2019 - 18:44
CCL, LUTS and Encoders
Thanks, I knew it was too good to be true   regards  
Wednesday, 21 August 2019 - 18:36
Jtag/ISP programming on input pins
Oooh, thank you for that, might just do the trick!  Just ordered an eval kit to have a play with.  There's no mention of PCINT so I'm guessing I need to look ate the CCL...
Wednesday, 21 August 2019 - 16:04
TWI Slave problems
Hi,   I have indeed, but it didn't help me though.  Firing up the protocol analyser showed that the slave was sending a NACK at times when being addressed with a write...
Thursday, 8 August 2019 - 16:22

Pages