Post Created date
Problems with 2 SPI Slaves
Hi,   That's the way the code is written yes.  However I've been reading up about SPI devices that don't release the bus.  While the MAX7221's look genuine, I'm not...
Thursday, 5 September 2019 - 20:05
Problems with 2 SPI Slaves
The max7219/7221 are wired thus (daisy)  or rather serial cascading.  These work just fine, it's the interaction with the other slave that's the issue.  The load/...
Thursday, 5 September 2019 - 16:14
Problems with 2 SPI Slaves
Think I may have found the issue, but not the solution.  It looks like the SS pin on the MAX is being held low most of the time and there's an overlap when both slaves have...
Thursday, 5 September 2019 - 15:28
Problems with 2 SPI Slaves
     Apologies, cut and paste error.  Been staring at the code way to long, here's the init  //Init SPI interface      // SCK MOSI CS/LOAD/...
Thursday, 5 September 2019 - 13:54
Problems with 2 SPI Slaves
The MAX7221 are daisy chained so they appear as 1 logical SPI device   regards  
Thursday, 5 September 2019 - 12:13
Problems with 2 SPI Slaves
Its been running for about 6 weeks on and off at 50 x expected speeds using the 4 x MAX7221's without problem so I don't think it's marginal.  It's TWI driven so I'm looking...
Thursday, 5 September 2019 - 11:20
Problems with 2 SPI Slaves
No,  thought the board was good to go after a month of testing the MAX.  wired some tiny cables on instead to get a look at the signals.  It's like fixing a...
Wednesday, 4 September 2019 - 20:02
Problems with 2 SPI Slaves
Yes that's all I have for the init.  To be honest it's been working fine with the MAX7221's for some time.  It's just been the addition of another slave.  MCP runs...
Wednesday, 4 September 2019 - 19:59
CCL, LUTS and Encoders
The speed won't be that fast.  5 detents/second, so 20?   regards  
Tuesday, 3 September 2019 - 20:13
Problems with 2 SPI Slaves
That's what I've done.  The data sheet speaks of a required delay after dropping the pin, and I'm allowing 1ms which should be plenty it's still unreliable.  The...
Tuesday, 3 September 2019 - 19:58
Problems with 2 SPI Slaves
I did wonder about the CS state of that port.  Have to say I didn't fully understand that section of the data sheet.   regards  
Tuesday, 3 September 2019 - 16:25
Problems with 2 SPI Slaves
I'm using studio, the lack of colours is just my bad pasting.   It's a little difficult to attach any probes on the board as it's all SMD.  I guess I'll have to...
Tuesday, 3 September 2019 - 16:01

Pages