Post Created date
Ensuring a TLC5947 device is disabled on power up.
Ahh,   Just to get this straight that's all I need to do with the setup below?   regards   5v -> 10k resistor ----- > Blank pin on TLC      ...
Tuesday, 10 September 2019 - 20:03
Ensuring a TLC5947 device is disabled on power up.
sorry, my bad, data sheet is here    Generally, if a pin needs to be high while an AVR is in reset, an external pull-up resister is used.   Thanks, but yes I...
Tuesday, 10 September 2019 - 19:52
Problems with 2 SPI Slaves
I take your point, and I would dearly have liked the time to figure it out software wise, but time was a constraint.  The purist in me wanted to keep going, sadly I ran out...
Tuesday, 10 September 2019 - 19:47
Problems with 2 SPI Slaves
You're absolutely correct but testing says otherwise.  The time of the overlap is 40 micro seconds.  Is it possible that this is the time it takes a pin to change from...
Tuesday, 10 September 2019 - 19:43
Problems with 2 SPI Slaves
No, I'm not using the SPI interrupt.   Changing the MAX7221's for ones I know are 100% genuine made no difference, neither did adding a pull-up on the SS line.   The...
Saturday, 7 September 2019 - 14:46
Problems with 2 SPI Slaves
0hhhhh!  Just to get my head around this, here's the sequence of events   TWI Stop/restart tells me I'm done receiving data and interrupt is triggered.  Run...
Thursday, 5 September 2019 - 20:42
Problems with 2 SPI Slaves
Agreed, but isn't this line going to block to prevent this?  Besides in testing I'm waiting 2 seconds between transmissions.   regards   // Wait until transfer is...
Thursday, 5 September 2019 - 20:31
Problems with 2 SPI Slaves
No I don't and wish I had.  At the time I didn't think I needed to.  Could wire one on to test though.  10k?   regards  
Thursday, 5 September 2019 - 20:17
Problems with 2 SPI Slaves
Hi,   That's the way the code is written yes.  However I've been reading up about SPI devices that don't release the bus.  While the MAX7221's look genuine, I'm not...
Thursday, 5 September 2019 - 20:05
Problems with 2 SPI Slaves
The max7219/7221 are wired thus (daisy)  or rather serial cascading.  These work just fine, it's the interaction with the other slave that's the issue.  The load/...
Thursday, 5 September 2019 - 16:14
Problems with 2 SPI Slaves
Think I may have found the issue, but not the solution.  It looks like the SS pin on the MAX is being held low most of the time and there's an overlap when both slaves have...
Thursday, 5 September 2019 - 15:28
Problems with 2 SPI Slaves
     Apologies, cut and paste error.  Been staring at the code way to long, here's the init  //Init SPI interface      // SCK MOSI CS/LOAD/...
Thursday, 5 September 2019 - 13:54

Pages