Type in the full discussion title or a part of it.
Discussion Title Created date
Ensuring a TLC5947 device is disabled on power up.
Hi Guys,   I have a string of TLC5947's attached to an ATmega328p.  There is a pin(Blank Pin) on the TLC5947 that disables output if it is high.  ...
Tuesday, 10 September 2019 - 19:33
Problems with 2 SPI Slaves
Hi Guys   Hope someone can help be out here, I'm going nowhere after a couple of days debugging.   I have an Atmega328p on a custom board with an external clock running...
Tuesday, 3 September 2019 - 13:53
Solved: atmega328p using an external oscillator
Hi Guys,   Put a new prototype board today (SMD) with the aim of using an external oscillator (4 pin variety) connected to XTAL1. (5v@20Mhz) It didn't work.  I...
Tuesday, 27 August 2019 - 19:32
CCL, LUTS and Encoders
Hi Guys,   I'm trying to figure out if I can drive more than one encoder (plan on using ATmega4809)    I've had a look at app note  AN2434 but I'm not up...
Wednesday, 21 August 2019 - 16:44
TWI Slave problems
Hi Guys   I've been making steady process on my AVR slave implementation but I'm having a few issues while testing   Setup Atmega328p as slave writing to a display via...
Wednesday, 31 July 2019 - 21:05
Chip suggestions with large number of I/O
Hi Guys,   A current project I'm working on has run into a bit of a wall.  Currently using an Atmega324PB to to service 16 encoders using PCINT (the chip has PCINT on...
Tuesday, 30 July 2019 - 20:41
Jtag/ISP programming on input pins
Hi Guys,   Struggling with an appropriate title, but my question is this.  I've designed a board with 2 x Atmega324PB's on it.  The purpose of the board is to...
Sunday, 28 July 2019 - 19:38
Memory corruption?
Hi Guys,   Wonder if someone could give me some pointers as to what's going on.   Studio 7   I have a program that runs on both an Atmega324pb and 328p   I'm...
Thursday, 11 July 2019 - 18:08
TWI Slave - How does it tell master it's done sending
Hi Guys,   If a master expects 4 bytes of data from a slave on a request, but the slave only has 2 bytes for a given register, how does the master know that's all it's going...
Thursday, 11 July 2019 - 14:50
Using EEMEM in a class
Studio 7   In the class include file I have the following declaration   uint8_t EEMEM NonVolatileString[16][18];   This fails to make with the following errors...
Monday, 8 July 2019 - 18:28
TWI Slave - How to detect Master has finished sending
Hi Guys,   I'm having problems determining when the master has finished sending to the slave.   I've got some code running on a Atmega324PB which is connected to an...
Sunday, 30 June 2019 - 19:08
Seg faults and 'could not read memory content' issues
Hi Guys,   After a productive few weeks I'm having a issue debugging array values. I've also had a few segfaults but only on a virtual PC.  I've attached a bare bones...
Thursday, 16 May 2019 - 16:16

Pages