Type in the full discussion title or a part of it.
Discussion Title Created date
Confused about timer overflows and remainder ticks
Hi Guys,   Looking for some help.  I'm really struggling to get my head around timers (yes I've read a lot of posts and tutorials, but I just not getting it just yet)...
Thursday, 17 June 2021 - 19:23
Confused by prescallers
Hi Guys,   Wonder if someone can help.  I'm trying to track down an issue with a board I've put together which after a while 'appears' to stop all together   CPU is...
Monday, 7 June 2021 - 15:29
Most efficient way of analysing 64 bits
Hi Guys,   Looking for some inspiration.   Atmega328P connected to 4 tlc5940's providing 16 x 4 outputs.   The problem: I want to add individual outputs to a...
Tuesday, 11 May 2021 - 14:46
Setting SPI with 20MHz clock
Hi Guy's   I'm working with an ATMEGA328PB and an MCP2518FD (Canbus)   The 328PB has two SPI's 0,1 and I'm using the latter   The datasheet for the ...
Tuesday, 19 January 2021 - 11:05
Can bus v TWI/I2c
Hi Guys,   Just a sanity check.  I have some 16 encoders connected to an Atmega324PB with PCint's active.  Works great.  However, with TWI the master device (...
Tuesday, 1 December 2020 - 18:17
Simple timer with 20mHz clock
Hi Guys,    I'm trying to implement a simple counter to generate an interrupt every 2ms (roughly) so I can monitor pin change speed based on the counter.   I'...
Friday, 20 November 2020 - 11:51
encoder rotation speed detection
Hi Guys,   I know this subject has been raised a number of times, but I haven't found anything appropriate, or perhaps I'm not phrasing the search correctly.   I have an...
Thursday, 19 November 2020 - 20:27
Confused about timers
Hi,   Wonder if someone can hep me out   I'm working on some existing code to generate an interupt every 4096 clock cycles   // CTC with OCR0A as TOP TCCR0A = (1...
Saturday, 7 November 2020 - 23:22
Communicating with a TLC5947
Hi Guys,   I wonder if some kind soul could point me in the right location with the above.   I've designed a board with an Atmega328P and a TLC5947.  I tested this...
Tuesday, 17 December 2019 - 21:13
Ensuring a TLC5947 device is disabled on power up.
Hi Guys,   I have a string of TLC5947's attached to an ATmega328p.  There is a pin(Blank Pin) on the TLC5947 that disables output if it is high.  ...
Tuesday, 10 September 2019 - 19:33
Problems with 2 SPI Slaves
Hi Guys   Hope someone can help be out here, I'm going nowhere after a couple of days debugging.   I have an Atmega328p on a custom board with an external clock running...
Tuesday, 3 September 2019 - 13:53
Solved: atmega328p using an external oscillator
Hi Guys,   Put a new prototype board today (SMD) with the aim of using an external oscillator (4 pin variety) connected to XTAL1. (5v@20Mhz) It didn't work.  I...
Tuesday, 27 August 2019 - 19:32

Pages