Post Created date
USART Interrupt Keeps Firing with No Data Input on RXCIF Flag
Hi, I am not sure if it is relevant, but the 'garbage' data is always null.  The FERR frame error and RXCIF are always on, but there is no actual data there.  I have...
Tuesday, 7 January 2020 - 17:17
USART Interrupt Keeps Firing with No Data Input on RXCIF Flag
Doc, It is connected to an RS485 transceiver that is set up for RX only.  The unit will have times when it is disconnected from an RS485 input source, so I should probably...
Tuesday, 7 January 2020 - 16:24
USART Interrupt Keeps Firing with No Data Input on RXCIF Flag
Hi, From the datasheet: When interrupt-driven data reception is used, the receive complete interrupt routine must read the received data from RXDATA in order to clear the RXCIF....
Tuesday, 7 January 2020 - 15:54
USART Interrupt Keeps Firing with No Data Input on RXCIF Flag
Can I move a post, or just repost in the correct forum? Thank you, Tom
Tuesday, 7 January 2020 - 15:40
USART Interrupt Keeps Firing with No Data Input on RXCIF Flag
My apologies, ATTINY1604 with Atmel Studio. Regards, Tom
Tuesday, 7 January 2020 - 15:31
Program Will Not Enter Main While Loop
Thank you for the explanation, that did it! Regards, Tom
Thursday, 27 June 2019 - 19:30
Timer TCA 6X Slower Than Expected on ATTINY817
Excuse my ignorance, I am new to Atmel controllers.  How can I write to just that bit? Thank you, Tom   Edit:  Answered my own question with a search (from user...
Wednesday, 8 August 2018 - 17:27
Timer TCA 6X Slower Than Expected on ATTINY817
Hi, Thank you for the quick response.  I missed the section in the datasheet talking about the scaler for the peripheral clock:   After any Reset, CLK_MAIN is provided...
Wednesday, 8 August 2018 - 17:07
Bitwise Operation is not Producing Expected Result
Thank you, this was instructive to me.  I will have to learn some more about using/reading the assembly code. Regards, Tom
Wednesday, 8 August 2018 - 16:30