Post Created date
Mega128 Port F R/W
Good news; the new assembler (2.0 Beta) will fail assembly if the operand of OUT is out of range :) C:\work\test\test.asm(6): error: Operand out of range -Geir
Tuesday, 22 June 2004 - 07:33
error dll to install the avr studio 4.9
It also say: "During installation you might get messages telling you the installer is trying to access files protected by windows. Ignore these and press Ok." Did you try this? -...
Friday, 11 June 2004 - 09:24
When I use ICE50 for Mega8515(PDIP),what adapter I can use ?
It's the m162 adapter. It is described in the ICE50 user guide under Connecting ICE50->Select Correct Personality Adapter. -Geir
Thursday, 10 June 2004 - 07:43
my simulator only has support for atMega128. What is wrong?
Do a search for xml parser in the forum and you will find a lot of threads identical to this. -Geir
Monday, 24 May 2004 - 07:18
Studio 4 wont detect my JTAG ICE
The very first thing you should do is to upgrade to Studio 4.09 and try again. You can set the clock fuses by using the programming interface in AVR Studio, with your JTAGICE. I...
Friday, 14 May 2004 - 07:26
Simulation problem
It's the well known XML parser problem. Make a search on the forum or read the install notes that came in the studio 4.09 archive. -Geir
Friday, 7 May 2004 - 11:34
Peculiar mega128 SPM behaviour (CPU Bug ?)
You must have some old pdfs, I find no reference to ESPM in my mega128 datasheet nor in my instruction set manual. SPM is used (with RAMPZ) to program the entire memory space. And...
Friday, 7 May 2004 - 08:35
Peculiar mega128 SPM behaviour (CPU Bug ?)
It's not hidden at all; this is from the instruction set manual, on LDD Z+: The RAMPZ Register in the I/O area is updated in parts with more than 64K bytes data space or more than...
Thursday, 6 May 2004 - 18:10
Peculiar mega128 SPM behaviour (CPU Bug ?)
Sounds like the Z pointer is not properly set at page write, causing you to write to a different page than expected. Perhaps the ram access is done with the Z pointer? -Geir
Thursday, 6 May 2004 - 17:40
AVR Studio 4.09 Build 338 Installation Errors
From the file called "Installing 4.09.txt" supplied with AVR Studio (inside the self extracting archive): *During installation you might get messages telling you the installer is...
Thursday, 6 May 2004 - 06:44
Source code in trace when using ICE50
This is probably not very helpful for you, but it works fine here. I'm using mega128 with IAR 1.50 and 2.28 on win2k (not sure which ubrof versions) and I've tried both serial...
Friday, 30 April 2004 - 11:36
A novice question (compiling?!!)
jbosley, You didn't read the options good enough: -o ofile Put output in 'ofile'. Default is the same name as the input file, but with extension 'obj'. -d dfile...
Thursday, 29 April 2004 - 06:26

Pages