Post Created date
Strange unlogical probelems on device
Hi There! There seem to be one error with one of your interrupts. There is one occurrence of __bad_interrupt. This probably means that one of the signal names are typed wrong. It...
Sunday, 17 November 2002 - 14:41
Strange unlogical probelems on device
Hi There! Well, given that the call tree isn't too deep, there should be enough SRAM to provide stack. The stack gets used pretty fast if there are functions calling functions...
Friday, 15 November 2002 - 15:23
Strange unlogical probelems on device
Hi There! Well, if the MCU is set to atmega128, the avrmega128.x linker file should be used as default. One thing you could try, if you haven't allready tried this. Make sure...
Friday, 15 November 2002 - 14:51
Problem with GCC3.2 and Uartinterrupt
Hi There! This is not a avrgcc bug, __bad_interrupt comes from the fact that you've used a signalname that doesn't exist. I can't seem to find either __vector_14, SIG_OVERFLOW1 or...
Tuesday, 12 November 2002 - 08:20
W2K fails hard with 'AVR' button
Hi There! Read the following thread: http://www.avrfreaks.com/phorum/... I believe that your problem is related to what I describe in the above thread. Regards gtoo
Thursday, 7 November 2002 - 16:18
gcctest7 build errors
Hi There! Search this forum, this topic have been anwered before. Search for "Nordic Object file".... Regards gtoo
Thursday, 31 October 2002 - 07:39
again a question concerning elfcoff
Hi There! Yes there is. If you don't need the coff file, just comment out the section in the make file. The makefile you're interested in is in c:\avrgcc\avrfreaks, and called...
Wednesday, 30 October 2002 - 08:40
elfcoff generates corrupt .cof file when .text exceeds 16k
Hi There! One place you can look at is : http://savannah.nongnu.org, this is where the avr-libc project is housed. There is just one thing I'm not quite sure about, and that is...
Tuesday, 29 October 2002 - 07:46
atmega128 and strings
Hi There! Too bad! :(( I had a look at the elfcoff code myself a couple of month ago, and when I found no comments, I gave it up. I didn't have the time to spare to do deep...
Sunday, 27 October 2002 - 19:48
atmega128 and strings
Hi There! Very interresting! I have to test this. There are a few concerns, tho. What happens if the .text section together with the .data section is bigger than 64kb? I think...
Saturday, 26 October 2002 - 21:28
error on accessing ext. SRAM
Hi There! I think the problem is that the decalration of your data section is wrong. try the following: data (rw!x) : ORIGIN =(0x800000+0x1100),LENGTH = 60K or read the...
Thursday, 24 October 2002 - 16:43
Urgently need help on External SRAM please
Hi There! I'm using external ram with my system and it works great. I haven't used buffers that large, but there shouldn't be any real big problems. The only way you can get one...
Thursday, 24 October 2002 - 16:31

Pages