Post Created date
Prescaler causing a timing error? Why?
I know the error is less than half a second over 3 days because I've got it running next to a radio clock which of course is accurate to within thousandths of a second.
Sunday, 26 May 2019 - 20:14
Prescaler causing a timing error? Why?
>WHAT? 1 in 25 is 4%... Sorry, was a typo. Corrected now.
Sunday, 26 May 2019 - 17:20
Prescaler causing a timing error? Why?
I'm still mystified about why the clock error is occuring. Since my previous posts the clock has been running at near to 100% accuracy as expected using a crystal. I'm not sure...
Sunday, 26 May 2019 - 15:53
Prescaler causing a timing error? Why?
Datasheet = manual. It's a big datasheet!
Saturday, 25 May 2019 - 17:37
Prescaler causing a timing error? Why?
Ahhhhh. Thank you. So it's a delay really. Should be a bit of a warning in the manual about how this can throw things out I would have thought?
Saturday, 25 May 2019 - 17:00
Prescaler causing a timing error? Why?
So really as far as the timers are concerned the start value is always FF or FFFF. I must have missed that little gem in the manual somewhere!
Saturday, 25 May 2019 - 16:47
Prescaler causing a timing error? Why?
Scroungre wrote: 'cause they start at zero.  S. Yes I understand they start at 0 but if you put 1 into the compare register then theoretically that would measure 1 period...
Saturday, 25 May 2019 - 14:33
Prescaler causing a timing error? Why?
Thanks for the suggestion that the error was caused by a 1 count difference in the compare register. I think this is it. I was using a compare register count of 125 at the time....
Saturday, 25 May 2019 - 11:38
Prescaler causing a timing error? Why?
> How are you measuring this 0.8%? The software counts the number of interrupts that have occurred. When using prescaler that is not set to 1 the error over time amounts to...
Saturday, 25 May 2019 - 07:27
Software bug causes AVR hardware error?!?!?
Ahem, **embarrassed face**, it seems that the programmer must leave the AVR registers zeroed, but I checked and my offset register (added to Z) was not initialised. So after a...
Tuesday, 6 April 2010 - 22:16
IJMP irregularities after reset?
Quote:Have you verified that the OFFSET and ZERO registers contain appropriate values? Ahem, **embarrassed face**, it seems that the programmer must leave the AVR registers...
Tuesday, 6 April 2010 - 21:53
Software bug causes AVR hardware error?!?!?
js wrote:Are you using FULL SWING mode for the oscillator? At times the low power osicllator mode can cause "issues" at high frequncies. Yes, full swing oscillator, longest reset...
Tuesday, 6 April 2010 - 21:02

Pages