Type in the full discussion title or a part of it.
Discussion Title Created date
SAMD20 I2C not working on Sercom 2/4.
Hi,   I have a custom board using a SAMD20. I  have two USART ports and two I2C ports. Both USARTs work fine. The I2C ports are on SERCOM 2 and 4. Neither of them work...
Monday, 10 July 2017 - 05:57
Atmel studio 7 debugger does not work if I2C slow clock is 32KHz
Hi, I'm using Atmel Studio 7. I have a board that uses SAMD20 and I'm trying to configure I2C on Sercom4. According to SAMD20 datasheet, section 27.6.3.1 (see below), we should...
Thursday, 6 July 2017 - 20:11
Unable to prgogram SAMD20 with Atmel ICE and Atmel studio
Hi,   I'm using Atmel Studio 7 and Atmel ICE to program a SAMD20 device on our custom board.   I was able to program the SAMD20 several times. I then used Tools->...
Wednesday, 7 June 2017 - 02:46
ASF project with user board startup files
Hi  I'm still quite new to Atmel Studio. So far I have been playing around with SAMD20 xplained pro. Now I want to create a project for a custom board using ASF. I used http...
Tuesday, 2 May 2017 - 20:36
SAM D20 mux and pin settings
Hi,   I'm using a SAM D20 Xplained pro board and having some difficulty understanding how the muxing works. I'm using Atmel Studio.   This configuration works for me...
Thursday, 16 March 2017 - 18:55
Atmel SAM D20 USART not working
Hi there,   I bought an Atmel D20 Xplained Pro board. The BLINK_LED project works fine so I know the board is working.   I then then moved to testing the USART in polled...
Friday, 10 March 2017 - 16:47