Type in the full discussion title or a part of it.
Discussion Title Created date
AVR Studio 4.19 TIMSK Error
Why would this set bit 5?         TCCR1B = (1<<WGM12) + (1<<CS10);     OCR1A  = nnnn;     TIMSK...
Tuesday, 20 August 2019 - 13:12
AVR Studio 4 WinAVR upgrade to?
Sorry I don't like bloatware. I have skipped over Studio 5 as I remember it riddled with vermin and lice. So after trying to install Studio 7 and failing for "some features could...
Wednesday, 14 August 2019 - 12:30
mega328 includes?
I can't seem to find either m328def.inc or m328pdef.inc in the default directories. Does anyone know what or where they are located? I tried a few GitHub .inc's but the chip will...
Monday, 8 October 2018 - 15:34
AVR Dude reprogrammig Signature Bytes
My question is this. Can anyone who has had experience in either performing or is able to decipher the terminal commands to fix a Mega48 which was overwritten by a bad programmer...
Sunday, 16 August 2015 - 19:15
Set Sim Speed Studio 5
Is it possible to set the project-debug-sim speed when running Studio-GCC like in Studio 4? I have looked through about every menu in the bloated thing. I still don't see it....
Sunday, 12 February 2012 - 19:46
Bit toggling (or com'ing a bit) [solved - misunderstood SBR]
When the following is executed in either simulator 1 or 2 in Studio 4, the I/O toggle works but not the register toggle. So can someone tell me what's wrong? Another simulator bug...
Friday, 18 February 2011 - 19:03
INT0 not acting correctly
Here is a question. When I simulate an INT0 interrupt (using a PIND toggle low-high-low etc) in Studio setup as rising edge only (11), it acts as though it is set up as any level...
Tuesday, 8 February 2011 - 21:47
Frequency Division on T2313
After searching and trying to understand basic timer functions, I am still a little in the dark as to advanced functions. What I am trying to do is divide a variable frequency...
Monday, 2 February 2009 - 09:52
Rotary Encoder in ASM
Well after 1 week at this, I have been unable to make my rotary encoder software work 100% bug free. I can make the direction output an flash 2 LEDs at the 10 Ms rate, but there...
Tuesday, 25 November 2008 - 15:59
What kind of weirdnes here comes be4 me? PORTB Pullups NG
I have gone over this again and again. While stepping through, all of PORTB stays high in the i/o view. My code is good, it simulates properly, but when put through the STK-500 it...
Tuesday, 15 January 2008 - 16:45
Pullups on 8515 (ok) vs. M8515 (ng)
Hello all, been a year since I have been coding and am by no means an expert but, capable. I program an 8515 with pullups on PORTD and all is well. I program a M8515 and no...
Tuesday, 8 January 2008 - 20:36
R0-R31 Not visible anymore in I/O view
For some reason when I updated to the latest Studio version, my register I/O view went away. I'm looking for the view as shown in the tree in the attached file. Any help? Here is...
Monday, 7 January 2008 - 16:59

Pages