Type in the full discussion title or a part of it.
Discussion Title Created date
How to Make Unclean
Oops. I used the make clean command and it deleted a file called Global_Definitions.cpp (right after I commented it out in my makefile). Kind of like shooting yourself in the...
Monday, 12 May 2008 - 17:42
Passing Argument by Referance, Compiler Error
I am trying to write my first function that uses arguments passed by referance and I am getting a compiler error. void accumulate(uint32_t...
Wednesday, 7 May 2008 - 00:18
Variables Local to Interrupts
As an amateur programmer, I did the amateur thing and defined almost all my variables globally. Now that my code is 9 pages long I am going back through the code and organizing...
Thursday, 1 May 2008 - 18:16
UART cable length
I am starting a design with two MCUs that communicate using the UART. One MCU reads a sensor value and sends the data to the second MCU that is about 20' away. I would like the...
Saturday, 22 March 2008 - 18:48
Fried MOSFETs
I attempted my first H-bridge design and I keep toasting my MOSFETs. My battery voltage is 7.5V and my motor terminal resistance is 1.94 OHM. This would give 3.9 Amps worst case...
Wednesday, 28 November 2007 - 23:06
Causes of a program reset
I am having a glitch where my program runs fine for several minutes and then resets without warning. I can tell when my program resets because I flash my LED's in a specific...
Thursday, 18 October 2007 - 23:22
My Mega is failing 2nd grade math (710 - 624 = 7?)
Hello all. This one's a duesy. If anybody can help shed some light on this bug I would be very greatful. Background: My chip is an ATMega644 @ 12 MHz. Timer1 is set up to...
Thursday, 18 October 2007 - 20:29
Quadrature Encoder Velocity Glitches
I am trying to measure position and velocity from a quadriture encoder using an ATMEGA644 @ 12MHz. I have 4 interupt sources: 1. A/D conversion complete 2. External Interupt 0 (...
Friday, 28 September 2007 - 22:06
Op Amp Help, Please
I am using an op amp as a differential amplifier to convert a sensor output to an appropriate input. It works exactly as expected except for some reason the output wont go below ....
Wednesday, 5 September 2007 - 20:00
Using Data Structures
My code is not compiling. Am I trying to use too much C++ for the C compliler? All the C++ I know is self-taught, so I could be making a very basic mistake. Here is my code...
Tuesday, 4 September 2007 - 17:36
MCU Recommendation
I am currently using an ATMEGA32 for a project where I am reading accelerometers and a gyro and making angular calculations. It's working out pretty well so far but I am starting...
Tuesday, 5 September 2006 - 18:04
How long of a 32bit array can I use
My code ceases to function when I add the following line to my program and load it on my ATMEGA16: uint32_t arctangent[255] = {61338,62565,63786,65001,66209,67411,... (you get...
Thursday, 31 August 2006 - 16:47

Pages