Post Created date
I2C Library Problems with ATtiny817
Good news everyone! I was able to get the TWI library from the Atmel Start example working with my code. Along with a couple of other smaller timing issues, the big problem was...
Wednesday, 23 November 2016 - 16:47
I2C Library Problems with ATtiny817
softpdx wrote: I see you are no longer using the alternative pins, which is good, keep it simple until the basics work.   Okay, I am super new at this too. I have not used...
Tuesday, 22 November 2016 - 21:12
I2C Library Problems with ATtiny817
softpdx wrote:   I am using the USART and TWI at the same time and I am able to use the primary SDA/SCL pins on PB1/PB0. I have some basic, hard fought code, to get the TWI...
Tuesday, 22 November 2016 - 20:48
I2C Library Problems with ATtiny817
Update: I got the TWI communication working (kind of) using the PB1 and PB0 pins (although I didn't have the USART0 module enabled so we'll see what happens when I add that in)....
Tuesday, 22 November 2016 - 19:34
I2C Library Problems with ATtiny817
js wrote: to PA1 and PA2 (SDA and SCL, respectively) Where did you get that from? The TWI pins are on PB1 (SDA) and PB0 (SCL)  by default, PA1 and PA2 are only usable...
Tuesday, 22 November 2016 - 16:45
I2C Library Problems with ATtiny817
jgmdesign wrote: Ok. Thats good. Another dumb question....are you powering the sparkfun board from the same supply as your AVR? If not do you have the grounds tied together? Just...
Tuesday, 22 November 2016 - 16:39
I2C Library Problems with ATtiny817
I'm interfacing with a Sparkfun magnetometer breakout board that has 4.7k pullup resistors on the SCL and SDA lines on its end.
Tuesday, 22 November 2016 - 05:46
I2C Library Problems with ATtiny817
Also, the example project uses the equation (F_CPU/(2*F_SCL) - 5) (found in the at30tse75x.c file) for calculating the baud rate to feed into the TWI_MasterInit function. However...
Tuesday, 22 November 2016 - 04:33
I2C Library Problems with ATtiny817
js wrote: There is a sample project in AVR Start tha has a TWI driver in C, I'll point it out when I get back to my computer later on tonight.   I believe I found the sample...
Tuesday, 22 November 2016 - 04:26
I2C Library Problems with ATtiny817
Okay, that would be great. Thank you. 
Tuesday, 22 November 2016 - 02:34
I2C Library Problems with ATtiny817
Ok, I've fixed my previous problems and actually got my code to compile. However, the pins that I think should be the SDA and SCL for the TWI module are not outputting anything. I...
Tuesday, 22 November 2016 - 01:21
I2C Library Problems with ATtiny817
If it helps, here is the Build output from Atmel Studio:  ------ Build started: Project: headphones, Configuration: Debug AVR ------ Build started. Project "headphones.cproj...
Friday, 18 November 2016 - 20:26

Pages