Type in the full discussion title or a part of it.
Discussion Title Created date
Missing Section
Can anyone tell me what I'm doing wrong? I'm creating a .hex file with avr-objcopy.exe (like I've always done in the past), but one of my sections is disappearing. From cygwin, I...
Wednesday, 3 October 2007 - 22:16
Stack Underflow
I'm using AVR Studio 4.13 #528 to simulate an 8515. My C code was compiled with gcc and I'm not doing anything "clever" to the stack. I am merely calling a function and returning...
Monday, 16 July 2007 - 23:40
Breakpoints
Breakpoints used to work great for me back with the old version of AVR Studio, but not so hot now that I've upgraded to build #528. I add a breakpoint to a line and nothing...
Thursday, 28 June 2007 - 15:46
Simulation Goes "POOF"
I started using AVR Studio 4 about a year ago when I was doing extensive simulations on my code. Everything worked great, then I moved on to emulation when the hardware was ready...
Wednesday, 9 May 2007 - 20:55
Defining an EEPROM location for a variable
I've got two structures that I want to appear in EEPROM and I'd like to define where these structures are located. I've boiled my program down to the bare essentials so I could...
Wednesday, 24 January 2007 - 22:46
Workaround: AVR Studio 4 crashes debugging multiple sections
This is not a great workaround, but it's better to debug in assembly than not to debug at all: 1. Compile your code as usual into .elf, .hex, and (optionally) .eep 2. Strip all...
Tuesday, 11 April 2006 - 21:51
How do I move the initialization data in Flash?
I'm compiling some code for an ATmega32 with avr-gcc 3.4.5 and I'd like to partition the Flash as follows: vectors, .text, & variable initialization: 0000-35FF update1_app:...
Sunday, 9 April 2006 - 23:57