Post Created date
How does (avr-)gcc/g++ know of default include directories?
I keep making reading mistakes.. :s Sorry! It seems GCC defaults to /usr/include   To list includes: a@elite:~$ `avr-gcc -print-prog-name=cc1` -v ignoring nonexistent...
Tuesday, 24 October 2017 - 20:53
How does (avr-)gcc/g++ know of default include directories?
JohanEkdahl wrote: As far as directory structure, my build comes out essentially the same as Atmels tool chain. Neither has "everything in the same folder". That would simply not...
Tuesday, 24 October 2017 - 19:16
How does (avr-)gcc/g++ know of default include directories?
According to: http://www.nongnu.org/avr-libc/user-manual/install_tools.html Everything should be in the same folder, so these 2 lines would be the ones that breaks the tool...
Tuesday, 24 October 2017 - 10:02
Need Help with AVR-based UV Exposure Unit
Kartman wrote: You mentioned using pcints. Use interrupts when you need microsecond response. As well, when using external interrupts, be they pcints or int0,1, you want to ensure...
Tuesday, 24 October 2017 - 08:20
Need Help with AVR-based UV Exposure Unit
Kartman wrote:There are encoders and there are encoders! A manual encoder (as in the twisty knob type) are unlikely to generate 1000 pulses per second, thus interrupts are...
Tuesday, 24 October 2017 - 07:52
Need Help with AVR-based UV Exposure Unit
I highly recommend https://www.avrprogrammers.com/howto/quad-encoder as a read on how to improve your handling of the rotary encoders. I used the pin change interrupt...
Tuesday, 24 October 2017 - 06:26
TWI / I2C Not Working (Solved)
SleepyOak wrote: That seems to be a Master I2C Library, do you know any good ones for slave?   Sorry, I had some beers too many yesterday.   I haven't tried it, but the...
Wednesday, 27 September 2017 - 08:05
TWI / I2C Not Working (Solved)
Hi,   I suggest that you instead try Petery Fleury's i2c lib. Which works great! And I think you need to re read the TWI section in the datasheet if you want to DIY.
Tuesday, 26 September 2017 - 12:38
debugWIRE via USB UART
Well, I have my first problem. It hits a breakpoint every time after finishing main, even though there isn't one there.   Unconnected. > l /...
Monday, 25 September 2017 - 13:57
debugWIRE via USB UART
JohanEkdahl wrote: Very interesting! But, Uh! What I don't have handy right now is that darn diode..   I didn't see any diode specs, so I guess "everything" works. Just...
Monday, 25 September 2017 - 11:32
debugWIRE via USB UART
gchapman wrote: Yes since mEDBG is not available as an orderable part. Advantage AVaRICE since that's an AVR GDB server; dwire-debug has an issue to finish its AVR GDB server...
Monday, 25 September 2017 - 08:29
debugWIRE via USB UART
Cool stuff! Might work out better than the current ICE/AVaRICE setup. Thank you for the tip!
Saturday, 23 September 2017 - 18:28

Pages