Type in the full discussion title or a part of it.
Discussion Title Created date
SPI Master Mode Bit Won't Set
I'm having trouble setting my Atmega16u2 as an SPI master. When I try to set SPCR's MSTR bit to 1, the value in the register stays 0. The data sheet states:   SPCR • Bit 4 –...
Wednesday, 29 November 2017 - 04:29
Can unplugging Atmel ICE brick chip?
Is it possible to unplug an active Atmel ICE (connected to an AVR via ISP6) at the wrong time and render the avr chip in an unusable state?   Some background; I plugged my...
Sunday, 26 November 2017 - 23:29
Looping CDC Message Stops Prematurely (USB, LUFA)
My LUFA program successfully turns my Atmega16u2 into a Virtual Serial CDC device and I can get serial messages to show on my host terminal, but for some reason the terminal stops...
Wednesday, 22 November 2017 - 20:45
Inconsistent Messaging Behavior (LUFA Serial Comms)
I have the joy of debugging a C program on my Atmega16u2 using only serial comm messages over USB. I'm noticing weird behavior; the debug strings i'm trying to send in the if(...
Tuesday, 7 November 2017 - 20:47
avr-gcc Command Not Found: Error 127
I've been using windows cmd prompt to compile LUFA demo projects for the past few days, but for some reason the make all command won't run anymore and I see the following in...
Saturday, 4 November 2017 - 03:40
LUFA Code Works on Demo, Not in User Project
A bit of quirkiness thats been stumping me: I can load the LUFA VirtualSerial demo onto my chip and it works as expected, but when I try to run the exact same code from the...
Friday, 3 November 2017 - 04:36
Trouble Setting DWEN for Atmel ICE Debugging
I have a custom PCB using an Atmega16U2 and i'm connecting it to my PC directly via USB. When I program the uC I do so via Atmel FLIP over the USB port I designed into my PCB....
Wednesday, 1 November 2017 - 07:17
Cheapest Place to buy Atmel ICE
What's the lowest price Atmel ICE you guys know of online? I'm shopping for one and I'm seeing $130 for the full kit as the lowest offer from Microchip.com.
Saturday, 21 October 2017 - 04:12
Recommended Debugger?
Hi all,   I'm about to purchase my first AVR debugger and I want your thoughts; what would your debugger of choice be for debugWire based debugging with the pinout shown...
Thursday, 19 October 2017 - 23:34
Do Output Pins Send a 0 When Set?
Hi all,   I'm wondering, when I set a PORT pin to output, does anything get written to that pin immediately after its set? Clarifying; I have a few SS lines hooked up to pins...
Thursday, 10 August 2017 - 04:24
Can any IO pin be used for SPI Slave Select?
I have an Atmega16u2 and i'm trying to wire it to two SPI slaves. This chip has 1 predefined SS pin, PB0 on Port B. I'm designing an architecture like the one pictured below where...
Saturday, 5 August 2017 - 19:45
Communicating to 2 SPI Slaves with USART & SPI ports on Atmega16U2
I'm writing code for an embedded chip that consists of an Atmega16U2 connected to two devices via the port B SPI pins and the Port D USART pins (which can be used for SPI comms as...
Saturday, 5 August 2017 - 04:07

Pages