Type in the full discussion title or a part of it.
Discussion Title Created date
VTOR override fails... or not? (SAM S70 + Atmel ICE)
Hi all!   I had a weird issue with using another vector table position than the default (start of flash address (0x00400000)). The MCU is a SAM S70. I use this because I want...
Wednesday, 3 July 2019 - 16:02
SAM S70 + SAMBA (USB) transfer buggy for a multiple of 512 bytes?
Hi Folks!   I am about to make my preprogrammer application (on PC) that runs/uploads my special test software (and later the boot program) into an assembled PCB with...
Sunday, 17 February 2019 - 20:04
Atmel Studio 7 + Atmel ICE: cache writeback "anomalies"
Hi folks!   I have been facing some annoying things about handling the cache with AS7 + Atmel ICE. I use SWD interface for debugging, the MCU is a SAM S70 (Q21). An SDRAM is...
Friday, 15 June 2018 - 16:00
SAM S70 + SWD (Atmel ICE) does not reset peripherals while debugging?
Hi!   I've noticed in the last (much) months that there's something weird about the debugging with SWD in Atmel Studio 7. The MCU is ATSAMS70Q21A. The issue is that if I...
Thursday, 31 May 2018 - 11:54
Main Clock Frequency Counter (CKGR_MCFR) issues with SAMS70Q21
Hi folks!   Another issue detected...   So, the datasheet says eveything about the Main Clock Frequency Counter unit, it's easy as a "hammer". It counts some clock...
Thursday, 10 May 2018 - 20:48
SAM S70 on custom board + SWD + GPNVM bits (TCM) bits issue
Hello!   I was starting my project in 2015 with the ATSAMS70Q21 MCU and had quite much troubles, including AS7 bugs. The whole system then become a nicely working one, I...
Wednesday, 9 May 2018 - 22:03
Need a confirmation, a test to be made with the SAM V71 Xplained Ultra board and Softpack v1.5!
Hi Folks!   I have a quite weird issue on my Xplained Ultra board. The thing is something that is nonsense and I would ask You to check it on your own one!   I am using...
Saturday, 7 January 2017 - 22:01
Weird issue: interference between USB host and an independent core instruction...
Hi folks! This week has been spent to localize the issue... it's the weirdest thing I've ever seen on an MCU, despite I've seen a lot. I try to write the story in short words. I...
Thursday, 15 December 2016 - 19:05
SAM S70 TWIHS fails at high MCK rate and active HSMCI transfer
Hi folks!   I'm facing the new problem in my project. (Own board, ATSAMS70Q21 MCU.) The circuit is just working fine, software has a tiny OS, all modules seem to work good (...
Sunday, 16 October 2016 - 14:55
SAM S70 backup power consumption is high
Hi!   My newest trouble is about the title. After doing everything for the lowest power consumption (external components are switched off with a P-MOS, IO pins at its 'low...
Sunday, 28 February 2016 - 20:00
Atmel Studio 7 + Atmel ICE: SWD debuging a SAM S70: can't mask interrupts while stepping over
Hi!   I am now writing the code into my project that would require step debugging, but "step over" does not work at all and so it's impossible to debug. :( Do anyone know...
Monday, 22 February 2016 - 13:29
Split: SAMS70Q21 difference between LMA and VMA
Hi!   I am having a new issue that slows down the development, again.   I use SAM S70Q21 and  C/C++. The project is contains only some components yet and is a...
Saturday, 13 February 2016 - 20:46

Pages