Type in the full discussion title or a part of it.
Discussion Title Created date
Things Learned After First ATMEGA Based Product
I've just completed my first ATMeag162-based product (WooHoo! We're Shipping!) and am now selecting parts for the next project. Here is a few things I've learned... 1) The 16KB...
Saturday, 14 January 2006 - 21:24
JTAG ICE MKII Pod Connector Broken
My JTAG ICE MKII emulator is caput! The little ribbon cable connector on the POD is broken. I noticed that there is a stress releif (a rather large one!) inside the MKII, but...
Wednesday, 14 December 2005 - 21:24
ICCAVR Code Compression/Optimization
Well it was going to happen sometime... I hit the 16K program memory limit using ICCAVR STD V7. I'm surprised at how quickly so much program memory was used up. Oh well....
Friday, 2 December 2005 - 22:51
Atomic Access - Is This Method Safe?
Hello fellow AVR users! I am using ICCAVR V7 Standard and am using volatile variables greater than 1 byte in size (like an int or unsigned int). I need to disable ints to safely...
Wednesday, 2 November 2005 - 18:34
Getting IDR Feature to Work
I'm using AVR Studio V4.11.410 and wish to use the so-called IDR feature. My code (ATMEGA162) is writing to the OCDEN register, setting bit7 each time. I also wait for bit7 to...
Friday, 14 October 2005 - 00:24
USB Driver for JTAGICE MK2
I made the mistake of installing my JTAGICE MKII's driver before installing Studio V4.11.401. Now I can't get Studio to talk to the MK2. I've uninstalled the driver as well as the...
Tuesday, 11 October 2005 - 21:35
ICCAVR Exit Code 100
Just sent an email to support@imagecraft.com about an unusual error and exit code. Exit Code 100. Monday is Thanksgiving for us Canuks. I'm glad its not a holiday for our American...
Saturday, 8 October 2005 - 16:10
Befuddled by SPI SCK Pin Timing
I am interfacing a ATmega162V to an AT45DB161B Dataflash. The connections are straight forward (SCK to SCK, MOSI to SI, MISO to SO, /SS to /CS, and PB3 to /RESET). No other...
Tuesday, 27 September 2005 - 18:36
My JTAGICE MKII just went deaf! Help!
I went to upgrade the firmware in my JTAGICE MKII via USB and AVRSTUDIO V4.11 came back with an error saying block 44 had failed. Now I cannot connect to my unit at all! As is...
Friday, 9 September 2005 - 18:44
XMEX and JTAG on ATMEGA162/V
Hi everyone. I am hoping someone can shed some light on a design issue I am having. I wish to use the JTAG port for firmware development (have a MKII), but also use the full...
Tuesday, 23 August 2005 - 22:33

Pages