Post Created date
XMega Frequency & pulse width capture (twice) on same port
I am bumping this topic, because I am out of ideas how to fix this. Why is interrupt driver measurement not working, while polling is? Really need some more expert eyes looking at...
Friday, 29 January 2016 - 05:27
XMega Frequency & pulse width capture (twice) on same port
Oke, after some plying around and not getting it to work, I realized what the problem is. Not yet having a solution however might be someone here that can point me in the right...
Thursday, 28 January 2016 - 07:25
XMega Frequency & pulse width capture (twice) on same port
Hi Greg, sorry for my late reply. Had some problems with my Xmega. Blew up the first one and in between I changed the code and when I got my new experiment board rdy it seemed I...
Wednesday, 27 January 2016 - 08:47
XMega interrupt not working (some pins work some don't)
Found the code this morning. The above parts are just snippets from the complete code. While I was thinking it had to be in those parts. While I had no device to test I also...
Monday, 25 January 2016 - 14:25
XMega interrupt not working (some pins work some don't)
Hmz, strange, seems to be a problem with rpmcount[0] to rpmcount[8] -> till rpmcount[3] it works, above does not... Tomorrow a new day
Sunday, 24 January 2016 - 21:05
XMega Frequency & pulse width capture (twice) on same port
Found the problem, but I am still unable to solve it the correct way.   I call my function with this code:   pulseWidth1 = init_captureFAN1(1); period1 =...
Sunday, 10 January 2016 - 09:24
XMega Frequency & pulse width capture (twice) on same port
Been working on this problem the whole afternoon, however I am not able to solve how to reset/adjust a working input capture to switch from PW to FRQ.   void...
Saturday, 9 January 2016 - 18:26
XMega Frequency & pulse width capture (twice) on same port
Hi Greg, thanks for your reply. First I have to say, that I like your idea to use 1 timer for both fans. Because of the polling it does in my current set-up it will not do...
Saturday, 9 January 2016 - 07:38
Manipulate input TACH Frequencies and output multiple DDS based TACH Frequencies based on single timer
Kartman wrote:Each time you detect an edge in the input, toggle a port bit. Monitor the port bit with an oscilloscope. This should give a clue where the problem might lie.  ...
Wednesday, 6 January 2016 - 07:18
Manipulate input TACH Frequencies and output multiple DDS based TACH Frequencies based on single timer
After some time I restarted my project (converted to xmega), however I am running in a more general problem (not related to x/atmega). What I see is when running the code with a...
Wednesday, 6 January 2016 - 06:46
atMega program to xMega problem/learning
Yesterday I reviewed my code and changed the rest of it. I am aware that things work differently. I changed the rest of my code as well, at this moment it compiles without errors...
Wednesday, 30 December 2015 - 05:24
atMega program to xMega problem/learning
awneil wrote: Sebas06 wrote:only big difference is the references to object of the AVR Blinking an LED Using the debugger Using the UART etc, etc, ...   Thank you for your...
Monday, 28 December 2015 - 17:30

Pages