Post Created date
How can I make a uint96_t ?? (XMEGA 128A3U)
Ta Muchly! OK, (well - off - topic) but I'll share this:  
Tuesday, 26 April 2016 - 20:48
How can I make a uint96_t ?? (XMEGA 128A3U)
Pobody's Nerfect! 
Tuesday, 26 April 2016 - 13:54
How can I make a uint96_t ?? (XMEGA 128A3U)
Yeah, must've missed bitfields in my reading somehow - or never connected them with this.  The widest types are int16_t and uint16_t. No, Atmel Studio's version of gcc...
Tuesday, 26 April 2016 - 12:51
How can I make a uint96_t ?? (XMEGA 128A3U)
Thanks, I'll give that a shot! Never come across in AVR C the use of a colon like this...Time to study... UPDATE - FOUND at http://www.tutorialspoint.com/cp......
Tuesday, 26 April 2016 - 08:47
Debounce algorithms and power supply decoupling
OK, My bit of drivel... I'm using an XMEGA, but roughly the same, Processor isn't sleeping, but idling at 32KHz,,,, However... I use an iterrupt, but as soon as I enther the ISR,...
Friday, 18 March 2016 - 12:46
Pesky XMEGA A/D - GOTCHA, ya bugger!
Thanks! You helped me immensely! Yeah, did think about a P-channel/N-channel combo. - which already works, see bottom right of the schematic I posted.. But - code seems to give me...
Sunday, 13 March 2016 - 20:37
Pesky XMEGA A/D - GOTCHA, ya bugger!
(Replying to oneself is probably considered Bad Form, but I thought I'd publish an early - scrapped - design I still use for testing). Final is unrecognisable. For those...
Saturday, 12 March 2016 - 17:55
Epoch/Unix Timestamp to human readable and vice versa.
Ah, thanx! I'll see if I can get my 'beginner brain' round it. Must admit, Arthur's code had me very puzzled indeed... -Andy  
Friday, 11 March 2016 - 23:31
Epoch/Unix Timestamp to human readable and vice versa.
Hi, Arthur I know it was awhile ago, but did you ever get this going? -Andy  
Friday, 11 March 2016 - 23:26
AS7 (build 634) simulator doesn't start-debug-and-break,or stop.
HI, Jan.  This is a bit inconclusive, so I've done the following to ensure as much as possible is the same in AS6.2 and AS7: DLL is the one in the-last-one.zip' I've a half-...
Wednesday, 9 March 2016 - 17:06
AS7 (build 634) simulator doesn't start-debug-and-break,or stop.
Aha! Quick test, looks like that's got it! I'm off home early today, so I can try it more thoroughly on the two machines I have at home. Let you know more in a couple of hours or...
Wednesday, 9 March 2016 - 12:33
AS7 (build 634) simulator doesn't start-debug-and-break,or stop.
Sure! Two files - the "good - first run.txt" after restarting AS7, and let it hit the start of main, then 'continue' a couple of times, hit the BP as expected. Then I stopped, and...
Tuesday, 8 March 2016 - 19:09

Pages