Type in the full discussion title or a part of it.
Discussion Title Created date
AVR GCC strange behavior : missing code lines when mixing with asm code
It seems that lines are missing in the disassembly file when using __asm__   Here is my code : int8_t test(uint8_t * data) { uint8_t value; value=data[0]; value++; value...
Friday, 18 September 2020 - 23:23
Atmel-ICE & Avrdude for AVR® Programming In Mass Production
  In the application note AN2466 : "Using Atmel-ICE for AVR® Programming In Mass Production", atprogram can be used with serial number (-s option), "when more than one...
Saturday, 15 August 2020 - 14:52
Bios, Bootloader and Jump table with AVR GCC
I am trying to do an auto updatable app/bootloader through a wireless link (gsm link)   My micro-controller is a ATmega4809. In this µC, the flash is divided in 3 sections...
Tuesday, 21 July 2020 - 00:16
ATmega4809 : inline string is 0xff,0xff, ... 0xff, 0x00 ??
I had a function : void send2net(char * str) { char * p=str; while(*p!=0) { while((UCSR2A&(1<<UDRE))==0); // wait UDR empty UDR2=*p...
Tuesday, 23 June 2020 - 09:56
Programing ATmega4809 with Atmel Ice in UPDI
  I tried to install avrdude latest version from source to use atmelice_updi programmer.   So, I downloaded avrdude source from here : http://download.savannah...
Monday, 2 March 2020 - 20:47
make: *** [size] Error 1 and Comodo Defense+
Hi everybody, I had a problem when I build my current project. I am using AVR studio 4.19 build 730 with the Atmel Toolchain. Everything works fine until a moment and since...
Friday, 25 January 2013 - 13:54
XPlained : using onboard 12MHz osc to clock ATxmega128-A1
Hi, I need a crystal source for the ATxmega128-A1 on my Xplained Xmega-A1 board. Since 12MHz oscillator of the AT32UC3B1256 is only 2cm far from PR1 pin of J3, I tried to strap '...
Sunday, 21 October 2012 - 14:01
Inline assembly with xmega
Hi, I have a problem with inline assembly I have a naked isr that works fine with a AT90USB646 ISR(USART1_RX_vect, ISR_NAKED) { asm ( .... " lds r17,%[udr1] \n\t" .... "...
Thursday, 30 August 2012 - 12:00
avrstudio can't grab dos output stream
Hi everybody, In English: Summary of my situation: - OS = windows 98 - my computer is a notebook ( I don't know if it is important or not but I don't think so ) - avrstudio 3.53...
Monday, 18 February 2002 - 14:50