Type in the full discussion title or a part of it.
Discussion Title Created date
Can't get erase plane to work on dual plane device (SAM4C32)
Folks,   Got a SAM4C32C bootloader essentially working, but the one I thing I can't get going is the erase plane command.   I have the following:   uint32_t...
Wednesday, 29 April 2020 - 11:58
How do I watch an array as ASCII values, not hex or decimal
Folks,   Is there a way in Studio to look at the values in an array as ASCII values rather than binary values? Usually you can just pick it in the column select, but in...
Friday, 24 April 2020 - 16:24
Dual bank compiling and linking for firmare upgrades
I am using a SAM4C32 and I don't think I understand how the dual banks of flash memory work in terms of how you need to compile and link if you want to use the two banks ti run...
Thursday, 9 April 2020 - 14:00
Self Programming of Dual Bank SAM4C
Hi folks,   I've done bootloaders for SAM3 and 4S and SAM4E with single bank flash, and am attempting to do one for a SAM4C32.   Although I can program pages of flash in...
Monday, 6 April 2020 - 22:43
Eight SPI *and* a UART on XMega A1U?
Folks, I am looking for a device with eight SPI channels and a UART. A parametric search on the website indicates that, for example, the XMega A1U can do this. In fact, it says...
Friday, 18 July 2014 - 07:39
SD card initalisation nightmware
Folks, I've seen several of you have managed to get SD cards going, but I've been working on this for a week now (learning about SD protocol and FAT to begin with then writing...
Sunday, 13 January 2013 - 11:28
Program EEPROM using AVRISP Mk II
Folks, Is it possible to program one byte of the EEPROM using the AVRISP Mk II? My client is recompiling his program 32 times for the 32 processors on the system to set the...
Friday, 14 September 2012 - 12:33
Mega640 runs slowly when not using JTAG ICE
I have a really weird problem with a Mega640. It only runs properly when the JTAG ICE is plugged in. I have put a GPIO toggle in the main loop which goes at 307kHz. The main loop...
Thursday, 2 August 2012 - 22:42
Software for using AVR ISP II?
Folks, Is there a way to use to the USB ISP MkII programmer without having to use the s***ware that is Studio?! (I will go over my monthly bandwith allowance if I download the...
Thursday, 8 March 2012 - 12:00
EMC Emsissions - Are Pico Power devices better?
Folks, Just been testing some kit with a DSP banging away at 150MHz and an AVR at 8MHz and was surprised to find that the AVR (Mega64) is much noisier than the DSP. Although we've...
Friday, 23 April 2010 - 09:44
Why is Studio such a bloatfest? Firmware upgrade without it?
Does anyone from Atmel read this forum? If so, I would like to know why Studio has become such an hilariously big program! I don't use Studio (or indeed Windows) any more, but I...
Wednesday, 30 September 2009 - 13:06
Replacement JTAGICE Mk II header?
Folks, I have had a good look here and on Google and can find no answer to this, so I assume I'm *******, but I'll try anyway! I have two JTAGICEMkIIs that have broken ZIF sockets...
Tuesday, 21 July 2009 - 21:32

Pages