Post Created date
Unknown type name for structure
Ahhh the sweet smell of successful compilation!  Thanks you all for your kind & patient help! paul
Sunday, 26 March 2017 - 21:36
Unknown type name for structure
Good point, clawson, will fold my Includes.h into main.c, it really doesn;t serve any good purpose as a separate file
Sunday, 26 March 2017 - 21:18
Unknown type name for structure
Looking at the Output, I see:   C:\Users\paul\Documents\Atmel Studio\7.0\Nano_BatteryTender_0\Nano_BatteryTender_0\Includes.h(20,3): error: conflicting types for 'OutState'...
Sunday, 26 March 2017 - 19:00
Unknown type name for structure
Ahhh finally GOT IT, so I removed 'struct' from the function prototype.  I've still got lots of errors... Conflicting type for DetermineOutputState, for Mode, and...
Sunday, 26 March 2017 - 18:49
Unknown type name for structure
OK I *think* I've taken clawson's advice & removed tags.  I stopped declaring CurrentMode twice. void usart_init(uint16_t ubrr); char usart_getchar( void ); void...
Sunday, 26 March 2017 - 18:30
Unknown type name for structure
I haven't actually written the function, I've only yet declared it.  I did a 'Find' across the entire project, and that's the only instance.  Odd.  I wonder if AS7...
Sunday, 26 March 2017 - 14:56
Unknown type name for structure
Well I've taken several pieces of advice, and now have: typedef struct OutState{ uint8_t OutputCompare; int LED_Green; int LED_Yellow; int LED_Red; }; struct OutState...
Sunday, 26 March 2017 - 14:37
Unknown type name for structure
Clawson's fix solved my problem - thanks! Now I have another - "Storage size of CurrentMode isn't known" - the error cursor points to CurrentMode:   typedef enum {SHORTED,...
Sunday, 26 March 2017 - 01:17
Solved: Array passed to function
duh! Knew it had to be something stupid! thanks much, Kartman! paul
Monday, 20 March 2017 - 02:11
Solved: Array passed to function
The error points to the printf statement and all 3 Voltages(i) = 
Monday, 20 March 2017 - 02:09
SIMPLE timer trouble
Major Deuippe here - I wasn;t running my Timer_Setup code!!  Thanks all for your help, paul
Tuesday, 28 February 2017 - 01:02
SIMPLE timer trouble
Theusch - good point, will try it tonight - paul
Monday, 27 February 2017 - 15:55

Pages