Type in the full discussion title or a part of it.
Discussion Title Created date
possible compiler bug when setting UART baud rate
I've noticed that the first few bytes transmitted by my UART can sometimes get corrupted, then all later transmissions come through perfectly.  In an effort to solve this, I...
Friday, 18 December 2015 - 01:24
Help Web Links Do Nothing in AS7
I've noticed that clicking any help link in AS7 does nothing.  I believe these should open up a web browser and navigate to the relevant help doc (instead of doing nothing)....
Thursday, 1 October 2015 - 20:24
writing "16-bit" registers in one go
For several register pairs, the AVR-GCC includes specify shortened names, like EEAR that combines (?) EEARH and EEARL. For a long time, I've gotten away with writing these...
Monday, 20 June 2011 - 04:00
avr/eeprom.h addresses
Hello my fellow AVR-nauts. I'm looking into using the avr/eeprom.h include to manage my EEPROM reads/writes, but I'm confused about the addresses. eeprom_read_byte and...
Monday, 15 June 2009 - 19:01
volatile variable access
If I have a global volatile 8-bit variable (uint8_t or int8_t) that is shared between an interrupt service routine and the rest of the program, do I have to disable interrupts to...
Tuesday, 9 June 2009 - 15:59
external interrupt initially firing with input pullups
I'm running into a problem where my logic change external interrupts are firing once when first enabled at program startup. This only happens when I enable pullups on the...
Monday, 6 April 2009 - 19:44
fast stepper motor driving
I'm trying to figure out a good way to drive a stepper motor's step input fairly quickly (due to a large gearing ratio that has to be used). This is on a board with an atmega64...
Monday, 9 March 2009 - 16:03
unusual spi problem on mega324p
I was porting some code to the atmega324p and ran into an odd issue with the SPI. Narrowing it down to the smallest test case, I have a piece of code that just outputs a byte to...
Wednesday, 4 March 2009 - 17:33
avrisp mkII installer/uninstaller finished
I made a custom installer/uninstaller for the AVRISP mkII open source usb driver. Pretty handy if you need it. I use them for distributing the AVRISP mkII's to a few remote...
Thursday, 28 August 2008 - 20:45
avrisp mkII usb driver only
Is there a way I can install only the USB driver for the avrisp mkII without AVR Studio? I want to distribute a small application that uses AVRDude and the mkII to program an avr...
Wednesday, 2 July 2008 - 16:51
trouble programming fuses using avrdude with mega168
I'm having some problems programming fuses using avrdude on an atmega168. I tried to isolate the problem using the command line version (usually I just configure my WinAVR/avr-...
Tuesday, 20 May 2008 - 18:07
confusing WinAVR compiler warning
I just upgraded to the latest release version of WinAVR, and now my code (that always compiled fine before) is getting an odd warning: cutter_eeprom.h: In function '...
Monday, 3 March 2008 - 22:42

Pages