Type in the full discussion title or a part of it.
Discussion Title Created date
Weird error on bootloader code
I'm currently building a bootloader for my atmega4809 uC. When i use the standard bootloader as described in the manual, everything works fine when compiling the code. But when i...
Tuesday, 9 April 2019 - 14:01
State of gpio when Microcontroller is breaks
i am currently trying to figure out in what state my micronctoller GPIO will be when it breaksdown.   If you are running a program and the pin is in output state when the...
Thursday, 28 March 2019 - 10:40
Convert Interger array to string(char array)
hey guys, This maybe a stupid question but, i want to convert a interger array to a string on my xmega. I have been trying to do it with a for loop in different ways, but it isn't...
Tuesday, 12 May 2015 - 14:33
Weird software reset problem while waiting for DMA is done
hey guys, i'm currently trying to use DMA for my ADC conversions. But i got a problem when i'm waiting for the DMA is done with the whole transaction. It start at the beginnen...
Tuesday, 12 May 2015 - 08:27
Using SPID on xplained 256A3BU
Hello everyone, I'm currently trying to get SPI working on Poort D of my xplained board, but it isn't working. I have first tried to let it work on Poort C (SPIC). There...
Tuesday, 5 May 2015 - 07:33
Problem with detecting SD card on A3BU xplained
hello everyony,   I have got a problem with connecting to a SD card using he ASF functions. When i want to check the sd card it doesn't see any SD card and gives an error....
Tuesday, 7 April 2015 - 10:36
No data receiving via TWI
Hey guys, currently i'm working with a xmegaA3BU xplained bord and a MAG3110 device. I'm trying to get data from the MAG3110, but i don't get any   I have used TWI more then...
Wednesday, 1 April 2015 - 07:27
System clock stays at 24MHz??
hey guys, I'm currently working on a AtXmega 256a3bu xplained board. In my code i'm setting the system clock at 32MHz, but when i get the value F_CPU it says it 24MHz and also...
Thursday, 30 January 2014 - 13:47
Dynamic array of structs error
hey guys, I'm currently trying to make a dynamic array of structs with the fucntion Malloc. uint8_t N; typedef struct { uint8_t Adres; uint8_t Adres_read; uint8_t Adres_write...
Monday, 13 January 2014 - 13:25
TWI problem with XMEGA-A3BU Xplained and ATAVRSBIN1
hey guys, I have recently bought a Xmega-a3bu xplained board with a TWI ATAVRSBIN1 module. After i had ran some test program from atmel i tried to make my own program to get data...
Tuesday, 17 December 2013 - 07:39