Type in the full discussion title or a part of it.
Discussion Title Created date
Xmega AU manual USB section is a work of fiction
The USB section of the Xmega AU data sheet seems to be a work of fiction. Does anybody care? On page 240 it shows the USB transaction complete FIFO registers (FIFOWP and FIFORP...
Wednesday, 4 December 2013 - 12:18
LUFA help?
I'm trying to build a LUFA Usbtoserial project for my Xmega AU. I have not installed Doxygen. Is that a requirement? I see some #if !defined(__DOXYGEN__) in the code. I'm...
Monday, 28 October 2013 - 13:38
Add a C++ module to an ASF project?
I have built an ASF project using CDC USB, for educational purposes. I want to add some code. I'd like to write it with C++. I added a couple of .cpp files to the project but...
Tuesday, 3 September 2013 - 18:35
ASF USB CDC com port
I am testing with the ASF USB CDC sample project for my Xmega128a4. There is an atmel supplied driver. When I install the driver on my main Win7 machine, it uses COM10, even...
Thursday, 29 August 2013 - 14:23
Debugging C++?
I'm trying to debug my C++ code using Studio 6.1.2440 and my JTAGICE2. I can't see most of the data. I am using the default -O1 optimize option. Is that what I should use? I...
Tuesday, 23 April 2013 - 20:07
Latest Studio won't use my JTAGICE2
My Studio 6.0.1882 uses my JTAGICE2, but Studio 6.1.2440 won't use it. Does this mean I should buy a JTAGICE3?
Monday, 4 March 2013 - 18:51
GCC toolchain path contains spaces
Atmel put spaces in the GCC toolchain path. :roll: At least in Studio 6.1.2440 (beta). ....\Atmel Toolchain\AVR8 GCC\Native\3.4.2.876\avr8-gnu-toolchain\bin I do most of my builds...
Saturday, 2 March 2013 - 22:23
LAC, LAS & LAT
I wonder how the LAC, LAS and LAT instructions work. I can imagine two possibilities. I think they simply combine 3 instructions into 1. They do a fetch of 8 bits, wiggle one...
Monday, 4 February 2013 - 22:56
Xmega lockbits got set to zeros.
I tried to program my Xmega, and all attempts failed to verify. The first byte is 0x00 and should be something else. I tried the bootloader and PDI with the same result. Now I...
Sunday, 27 January 2013 - 22:01
Does Atmel look at crash dumps?
Or could it be that Windows doesn't crash in Norway? ;) I got another blue screen today. Atmel Studio was running, or rather it was just sitting there. I wasn't using it. My...
Sunday, 21 October 2012 - 22:45
Why new folder for new project?
Why must Studio create a new folder when I create a new project? Visual Studio doesn't insist on creating a new folder. If I have an existing folder that I want to use, can I...
Saturday, 29 September 2012 - 21:16
Atmel Studio strikes again.
Somebody seems to be lying to me. Atmel says it is installing a signed driver. Microsoft says otherwise. I got my first blue screen on this computer yesterday. It happened in...
Friday, 28 September 2012 - 19:36

Pages