Type in the full discussion title or a part of it.
Discussion Title Created date
Problem with gnu++11
When I try to copy one instance of a class to another instance of the same class, the compiler has a hissy fit.  It occurs when the object in the class is a bitfield and is...
Monday, 11 April 2016 - 14:26
Remove compiler option?
How do I remove a compiler option?  I think I knew how to do it at one time.  I am using AS 6.2.      
Saturday, 9 April 2016 - 23:33
Simulator factoid
To get the simulator to work, I have to set the Properties >> Tool >> Programming settings to "Erase Entire Chip".  If it is set to "Skip programming", it...
Saturday, 15 August 2015 - 21:59
Debugger I/O view doesn't show Xmega Power Reduction registers
I've tried Studio versions 6.2 and 7.0.305.  I've tried Xmega a4u and Xmega A3bu.   Also when testing the Xmega A3BU, it doesn't show the RTC32 registers....
Monday, 27 July 2015 - 17:58
Debugger shows incorrect EEPROM values.
I'm using Studio 6.2 SP1, build 1502.  I'm using JTAGICE mkII via PDI.  The EEPROM shown in memory window is pure garbage.  It bears no similarity with the actual...
Wednesday, 25 March 2015 - 18:42
 Volatile variables
    Cliff, I often notice this, but it always puzzles me.  It may be good advice, but I don't think all ISR/main shared variables MUST be defined volatile. ...
Friday, 13 March 2015 - 01:30
How to use dfu-programmer?
I want to try out dfu-programmer.  I downloaded the Windows program from here:  http://sourceforge.net/projects/dfu-programmer/files/dfu-programmer/0.7.0/   However...
Tuesday, 10 March 2015 - 13:49
A minor issue.
I guess someone failed to clean up after copying from Visual Studio.    
Monday, 26 January 2015 - 21:08
gcc problem with switch
There seems to be a problem with switch and more than 6 cases.   The CPU will sometimes jump into the wilderness.   It's not that simple though.    I...
Tuesday, 6 January 2015 - 22:03
A3BU Xplained board annoyances
It seems that to activate the installed DFU bootloader, a power-on reset is required.  A software generated reset or external reset won't do.  I have to yank the USB...
Friday, 26 December 2014 - 12:38
Debugger does not show RTC32 I/O registers
I'm debugging an A3BU on the Xplained board.  The RTC32 registers are not shown.   This chip has battery backup and an RTC32 module instead of the regular RTC module....
Wednesday, 24 December 2014 - 15:53
Secret message from Atmel?
I looked at the User Sig Row of the Xmega on my Xmega A3BU Xplained board expecting it to be all 0xff.  Instead I found this:     :...
Tuesday, 23 December 2014 - 00:19

Pages