Post Created date
1 wire bus non-starter
@Greg_Muth: the app note I link to actually uses a uart/usart so I guess we were thinking the same   Ilya
Saturday, 2 June 2018 - 16:37
1 wire bus non-starter
I don't know if it will help but Microchip has an app note (http://www.microchip.com/wwwappn...) with the corresponding code for tiny's and mega's but you should be able to easily...
Saturday, 2 June 2018 - 10:40
SDRAM board design tips
This document (http://ww1.microchip.com/downloa..., SAM4S Schematic Checklist) may well prove very valuable to you despite it not being for SAM E70 - I have not seen a similar...
Tuesday, 29 May 2018 - 05:18
Cant get SPI to work whit ILI9341 ASF on SAM4S xplained
I will look into the send byte command when I get a chance. The only theory I have about the CS pin behaviour is this table, and in particular the middle entry in that table (it...
Wednesday, 9 May 2018 - 12:45
Cant get SPI to work whit ILI9341 ASF on SAM4S xplained
Well actually thats very strange that the SPI isnt active. In any case, the way the SPI is supposed to work is that the SPI master needs to get the CS pin LOW for the...
Wednesday, 9 May 2018 - 09:45
Cant get SPI to work whit ILI9341 ASF on SAM4S xplained
Oh forgot to mention that the pin definitions I was talking about in the last post should go into your sam4s_xplained_pro.h file   Ilya
Tuesday, 8 May 2018 - 14:50
Cant get SPI to work whit ILI9341 ASF on SAM4S xplained
The only thing I can suggest (for the time being) is that you do a definition like this #define ILI9341_SPI SPI #define ILI9341_CS (PIO_PA31_IDX) #define...
Tuesday, 8 May 2018 - 14:33
Cant get SPI to work whit ILI9341 ASF on SAM4S xplained
Try and see if you now get anything on the LCD with that code  
Tuesday, 8 May 2018 - 13:54
Cant get SPI to work whit ILI9341 ASF on SAM4S xplained
The problem you have is that the ILI9341 per se is very "stupid" so you need to tell it what colour tables you want to use and so on. So your code in main.c should look something...
Tuesday, 8 May 2018 - 13:53
Cant get SPI to work whit ILI9341 ASF on SAM4S xplained
Right, at least you can try the following: In your ASF wizard, add "Display - AAT31xx Backlight controller (component)" In your actual code, have something like: volatile...
Tuesday, 8 May 2018 - 12:54
Cant get SPI to work whit ILI9341 ASF on SAM4S xplained
I havent looked at the code yet (something I will do in a sec), but I would check the connections between your board and your LCD if I were you just in case. Are you using a...
Tuesday, 8 May 2018 - 12:15
Cant get SPI to work whit ILI9341 ASF on SAM4S xplained
I certainly try and do my best to help out   Ilya
Tuesday, 8 May 2018 - 11:40

Pages