Type in the full discussion title or a part of it.
Discussion Title Created date
Multi project setup using solution... Best practice?
Hi all, currently I have my projects organized for AVR Studio 4 using some nasty workarounds to get the following structure: .\projects\project1
Tue. Apr 3, 2012 - 07:47 AM
Speeding down the system clock during debug session problem
Hi all, anyone noticed following behaviour in Studio 5 and 6: During runtime the software is switching between 4 and 1 MHz on internal clock. This works fine as long as there isn'...
Thu. Mar 1, 2012 - 04:00 PM
I2C Slave problem with stretching SCL
Hi, This time, I'm fighting with I2C and need some help with my Slave. I'm using the Hardware TWI on Master and on Slave Side. Everything is working fine, except one thing: When...
Wed. Feb 9, 2011 - 02:24 PM
Problems switching from 644p to 1284p
Hi Folks, I recently switched to the 1284p µc. In the beginning, everything was ok. The software was working fine. Now, after the code has grown a little bit more, I encounter...
Wed. Aug 4, 2010 - 11:40 AM
Calibration sometimes goes wrong
Hi Folks, I have a small problem. I'm using an external 32kHz XTAL to calibrate the internal 8Mhz oscillator to 7.3728MHz of an Atmega644P. The method I use is from Application...
Thu. Dec 10, 2009 - 01:02 PM
switch clock during runtime and cal. int. oszi to 7.37MHz?
Hi Freaks, I have some questions which I would like to discuss with you. - Are there any disadvantages when I change the CPU speed from 1Mhz to 4Mhz during runtime? Of course I...
Tue. Nov 17, 2009 - 12:03 PM
to hash or not to hash ?!
Hi freaks, As anytime I have a question. This time about Hash functionallity. Basically I want to calculate a hash value with 2 Bytes out of a 10 Byte value. Basically that would...
Wed. Oct 28, 2009 - 04:20 PM
How to forbit to link floating point stuff
Hi all, I have here a big project and running low on memory. Now I found a small problem in the code which lead to the inclusion of some floating point library stuff (I suppose it...
Mon. Oct 19, 2009 - 02:51 PM
Uart Baudrate calculation - am I missing something?
Hi all, in fleurys uart lib, there is a makro to calculate the uart baudrate: UART_BAUD_SELECT_DOUBLE_SPEED(baudRate,xtalCpu) (((xtalCpu)/((baudRate)*8l)-1)|0x8000) Ok. The...
Tue. Apr 21, 2009 - 10:10 AM
Memory test problem. Don't know what to do...
Hi folks, it's me again. Now I have my RAM test up and running in my application. And now there is a big problem which I don't know how to solve. First thing I learned was, that...
Mon. Nov 24, 2008 - 05:16 PM
My code (RAM-Test) is optimized away.
Hi all, I have this neat little SRAM Test: register unsigned char *p_val,*p_sav,i,sav; register unsigned char val; register signed char h; /* test all locations with...
Wed. Oct 1, 2008 - 10:54 AM
_low_level_init() / _init_startup *solved*
Hi Freaks, I have a function for IAR called __low_level_init(). I know, it is called before main(). Now I'm porting it to gcc. I allready found out, that I have to use...
Mon. Sep 29, 2008 - 11:34 AM

Pages