Type in the full discussion title or a part of it.
Discussion Title Created date
ADC broke when I switched from an ATmega16 to ATmega1284p
I ran out of memory and I switch the project I'm working on from an ATmega16 to an ATmega1284p. When I did my ADC broke. Here are my functions using the ADC: void...
Thursday, 10 March 2011 - 06:21
How do I know how much memory space is left?
I've been growing the code in a program I'm working on. The latest function I added is causing the program to behave very strange (LCD is printing garbage and the program seems...
Friday, 25 February 2011 - 05:56
Voltage Divider for 3.3v?
I have a board that primarily runs on 5v. I would like to add an accelerometer that runs off of 3.3v. I figured using a voltage divider would be the simplest way of getting 3.3v...
Friday, 22 October 2010 - 18:18
Circuit for monitoring battery voltage with ADC?
I would like to monitor the voltage of a LiPo battery pack that powers my AVR. Can I simply connect the 3.7v positive terminal of the battery to an ADC channel on my ATmega16?...
Tuesday, 24 August 2010 - 01:02
Unknown failure trying to make the MCU pause.
I am trying to create a sub-routine that is functionally identical to _delay_ms(). I am already using Timer0 for switch debouncing and it seems to interfere with _delay_ms()....
Tuesday, 27 April 2010 - 05:21
Bit shift and masking for PORTB not working?
I would like to control a LED on PB0. For the sake of readable code I would prefer to activate the IO port with this line of code: PORTB |= (1<<PORTB0); However this...
Wednesday, 21 April 2010 - 01:06
Connect all VCCs and GNDs?
I am laying out my first PCB with a ATmega16 in a TQFP package. I want to know if it is necessary to connect all of the VCCs to 5V and all of the GND to ground? Or are the...
Thursday, 11 June 2009 - 06:14
How to use printf with UART?
I would like to use printf with my UART. Below I have some code that I'm working on. #include #include int main(void) { float F_CPU = 1000000; float UART_BAUD_RATE = 4800...
Friday, 13 February 2009 - 07:55
Initialized Float Value Error?
I'm encountering an error with my float values. I was able to determine this error by using the AVR Debugger and monitoring the value of the float while I stepped through the...
Monday, 9 February 2009 - 19:31
Why will this code work on an ATmega8515 but not ATmega16?
I have a program below that will only work when I select ATmega8515 as the target device in AVR Studio4. It works properly for an ATmega8515. However if I install an ATmega16...
Wednesday, 21 May 2008 - 21:11
I'm looking for sample C code to write to the Hyperterminal.
I'm a newbie and I'm looking for some sample code of a C program that will send a string to the Hyperterminal on my computer. I'm using a STK500 with AVR Studio 4. In other...
Monday, 28 April 2008 - 18:50