Type in the full discussion title or a part of it.
Discussion Title Created date
Choosing a CPLD and a programmer for a hobby project.
Hi, I'm new to CPLDs; I would like to create a small PCB that connects an ATmega to an Altera MAX3000A(*) as a prototype and to learn some HW description language. The MAX300A has...
Fri. Dec 12, 2008 - 04:27 PM
How to place a variable at the end of the data segment
In a program I'm working on we have exhausted close to all available RAM. I would like to check if the stack is eating into the data segment. Of course I could fill the SRAM with...
Fri. Oct 17, 2008 - 12:08 PM
ATmega32U4 -- when?
Has anyone some information when the ATmega32U4 will be available? The press release said something about Q2 2008 (for volume). Thomas
Mon. Jul 28, 2008 - 11:52 AM
TWI vector riddle
I have blamed God, the Universe, GCC and Atmel (in this order; I wrote the code alone, otherwise I would have blamed anyone else involved as well) for this, but now I think the...
Sat. Jul 19, 2008 - 12:22 AM
Error handling for TWI
Hi all, this is (part of) my TWI ISR on a ATmega644 which acts as TWI slave: #define TWCR_ENABLE ((1<<TWIE)|(1<<TWEN)) #define TWCR_TWEA ((1<...
Wed. Jun 25, 2008 - 11:01 AM
How to reference a C symbol from an assembly file
Hi, I'm trying desperately to access the address of a C structure in a assembly file. E.g. if I have the .c file: typedef struct { uint8_t a; uint8_t b; } status_t;...
Wed. Jun 18, 2008 - 05:43 PM
Side effects in asm inline code (r1)
Hi, I have found a strange issue with avr-gcc (both 20071221 and 20080610). My asm code has side-effects, and I can't work out how to fix it. Basically, I have this routine that...
Tue. Jun 17, 2008 - 02:42 PM
Comments on Schematic sought (AT90USB647)
Hi, I'm drawing my first schematic, and I would appreciate some comments on my current result. In particular, I have the following doubts: R1 is 47K in AT90USB design, 10K in the...
Sat. May 10, 2008 - 02:42 PM
TWI slave on ATmega644: clock stretching does not work
Hi, I can communicate with a ATmega644 as slave on I2C and it works well on low speed. But if I try a clock frequency of more than 50KHz, I see some very strange effects: - The...
Mon. Apr 21, 2008 - 05:18 PM