Type in the full discussion title or a part of it.
Discussion Title Created date
ADC12DL080 Single-Ended Operation
I'm trying to figure out how i need to connect this adc. I have 0-2V signal that i want to convert. if i understand from the datasheet: Quote:However, if single ended-operation is...
Thursday, 28 March 2013 - 17:23
Quadratic encoder on stepper motor
Hi, I'm trying to use encoder with my stepper. Currently im reading encoder data with one channel connected on interrupt pin (INT0) and than in interrupt routine check second...
Monday, 10 September 2012 - 17:57
TFT LCD touch menu system
Hi, I'm working on project with 3,2" lcd display. I need to make menu system that will display menus and do some job on inputs. For input i use touch screen. I need different...
Saturday, 28 July 2012 - 12:53
Optimization flag -finline-functions
I have a problem with optimization in my project. If i compile with -O2 everything works fine. But when i use -O3 some functions doen't work properly anymore. I found out that...
Wednesday, 20 June 2012 - 14:01
Converting string to hex
i'm trying to convert 10 chars long string whitch contains hex values in assci chars into 5 byte values. uint8_t Str2Hex(uint8_t *str, uint8_t *addr) { uint8_t i; for (i = 0...
Monday, 11 June 2012 - 13:27
List of controlled devices
I'm building project where i will control several devices wirelessly. I want to have some array, where i'll have address, data values etc., for every device. Now i want to be able...
Friday, 8 June 2012 - 11:45
ATmega164A timer0
Hi! I'm having problem with getting timer0 to work. Trying to set it in CTC mode to give me interrupt every 8ms. Here is complete code. I can't find whats wrong, just don't get...
Sunday, 15 January 2012 - 14:46
ADNS-6010
So i'm trying to get adns6010 working, but with no luck. So far i succeded to upload firmware and everything, everything seems to be working except i get no motion data. All...
Wednesday, 27 April 2011 - 12:20
ATmega16 + ADNS-6010 problem
Hi, I'm trying to communicate with mouse sensor but having problems with spi. Every time i want to read some register i get 0xFF returned. This is my code in CodeVisionAVR. #...
Wednesday, 5 January 2011 - 19:53
ds18s20 and mega16
I'm trying to comunicate with temp sensor but wiht no sucsses. I found code on web and slightly modified it. Problem is that i don't get presece pulse. I connected sensor on pin...
Wednesday, 29 April 2009 - 21:53