Post Created date
Help with assembly
Thanks. That explanation makes sense. I've still got actual code testing to do and will comeback after I've had a chance to test. I don't want to keep making blind stabs at what I...
Monday, 16 April 2018 - 13:20
Help with assembly
skeeve, I'm familiar with shifting bits and bytes, but branching (the term) is unfamiliar to me. I'd need to research that. Total asm boob.   clawson, I'm going to do some...
Monday, 16 April 2018 - 13:02
Help with assembly
clawson, I've tried to cobble this together. Not sure if I have to declare the asm volatile twice (1 for the 4 bit and 1 for the 8 bit) Is this even remotely correct?   void...
Friday, 13 April 2018 - 22:25
Help with assembly
I'll have to try it out and do some study of your reply before it makes sense, syntax-wise. But I get what you're saying. And it makes perfect sense. The extra 4 bits, since it's...
Friday, 13 April 2018 - 21:57
AS6.2 "Path is too long"
awneil wrote:JimmyM wrote:I was also thinking it might be the space in the "Reflow Oven" folder name Spaces in file/folder names is another whole can of worms! Just Don't Do It! I...
Sunday, 13 April 2014 - 19:08
AS6.2 "Path is too long"
awneil wrote:Windows itself is a bit funny about its pathname length limits - the same path can be accepted in one context, but rejected as "too long" in another. In the examples...
Thursday, 10 April 2014 - 20:30
Hesitant to switch from AS4 to AS6.1/.2
OK. I'm up on 6.2 now with just issues around getting used to the UI. I added a flavour for WinAVR to AVR 8 bit and now I can compile with either to make sure I'm not just...
Wednesday, 19 March 2014 - 18:26
Hesitant to switch from AS4 to AS6.1/.2
I just upgraded the firmware on the MkII per AS6.1, and 4.18SP3 can still talk to it and program the device. Of course it doesn't like when 4.18 and 6.1 are both running at the...
Monday, 10 March 2014 - 14:05
Always choosing tool in device programming
I see that the build succeeded, but nothing about programming. I'll have a look at the AVRISP LED to see if there's data moving there. I'm working on the machine remotely at the...
Monday, 10 March 2014 - 13:53
Always choosing tool in device programming
I just installed AS 6.1 and imported a project. All very nice. But I ran into this issue as well. In AS4 all I had to do after setting things in the "Connect to the selected AVR...
Monday, 10 March 2014 - 13:12
Hesitant to switch from AS4 to AS6.1/.2
I think I'm going to jump in. I also see that I can set the "flavour" for the project and still use WinAVR20100110 if I so chose. I was wondering if the 2 versions would cause USB...
Monday, 10 March 2014 - 11:43
Hesitant to switch from AS4 to AS6.1/.2
Oh. When you put it that way. That isn't too bad. I'll look into __flash too. What else have you seen that might bite me?
Saturday, 8 March 2014 - 16:50

Pages