Post Created date
Build project error in Eclipse
I can't quite remember, but I think my AVR GCC was upgraded by the update manager. What it sounds like is I need to remove my current AVR toolchain and reinstall. Is 4.2.2 the...
Friday, 26 December 2008 - 20:38
Build project error in Eclipse
I was re-reading the sticky on building the AVR GCC, paying particular attention to this: Quote: 18-Nov-2008 Updated the scriptfiles to build binutils and insight without the -...
Friday, 26 December 2008 - 14:43
[TUT] [HARD] Use AVR Dragon with Linux without being root
This is fantastic information! I was able to use this to get my AVRISP MKII to work with AVRdude without using sudo on Ubuntu 8.04.
Thursday, 25 September 2008 - 13:58
Is it Codeblocks or my gcc-avr
Ok, I think I got it now. A rookie mistake on my part I guess. Thanks,kschwiRG, for suggesting that the included file weren't in my project. I was under the assumption that by...
Sunday, 15 June 2008 - 17:13
Is it Codeblocks or my gcc-avr
I cleaned avr-gcc and codeblocks completely off of my system (I think anyway) and did a fresh install. I still get the errors I was previously but it seems like only when I try...
Sunday, 15 June 2008 - 01:34
(Outdated) Script for building AVR-GCC 4.5.1 on Linux
Another excellent resource for installing CodeBlocks on Ubuntu Hardy 8.04 http://www.futuredesktop.org/codeblocks_on_ubuntu_8.04.html
Saturday, 14 June 2008 - 19:30
Is it Codeblocks or my gcc-avr
I'm not sure if this is what you are looking for but it's all I know how to get so far aside from what I've already posted: In file included from main.c:1: avr-gcc -gdwarf-2 -...
Saturday, 14 June 2008 - 17:44
Is it Codeblocks or my gcc-avr
I have set -mmcu and it's set in the Makefile as well. I think Lonetech might be on to something because it seems I have multiple installations of avr-gcc and I think I should...
Saturday, 14 June 2008 - 16:24
Is it Codeblocks or my gcc-avr
I think I got my path fixed, well I changed it and now get a new error anyway. Here it is: /usr/local/avr/lib/gcc/avr/4.2.2/../../../../avr/include/avr/io.h|301|warning: #...
Saturday, 14 June 2008 - 16:01
help install on Ubuntu
Just in case anyone else runs into the same problem and wants to know why, check the Ubuntu wiki. Apparently, Ubuntu by default uses dash (the Debian Almquist Shell) instead of...
Tuesday, 10 June 2008 - 20:38
help install on Ubuntu
Doh! I should have thought about using bash. I just remoted to my comp (called my wife and had her do it) and it worked. Thanks a million guys!
Tuesday, 10 June 2008 - 17:22
help install on Ubuntu
I had to go back and rebuild my toolchain, couldn't leave well enough alone I guess. I've done well so far up until the last step and am now getting this error ./buildavr-no-...
Tuesday, 10 June 2008 - 03:39

Pages