Post Created date
Looking for help with i2c(TWI).
Using the level shifter I can only conclude that maybe the clock signal has issues keeping up.   To explain in images. The scope is on the +5 end of the level shifter. At the...
Saturday, 30 January 2021 - 15:55
Looking for help with i2c(TWI).
Ok, with the 3k pull ups I see a max voltage of about 2v. IIRC that is teetering on the edge. The connected master does use 3.3 but from reading about it online it is 5 volt...
Tuesday, 26 January 2021 - 01:14
Looking for help with i2c(TWI).
ah, very good them. I thought most were saying an analyzer was better. Come to think about it I have an analyzer that also has analog, ill use that and report back.
Tuesday, 26 January 2021 - 01:11
Looking for help with i2c(TWI).
Ah, the datasheet says that the IO pullups are between 20k and 50k. A simple test would be to put a 3.3k on each line and see if that helps. Seeing the same results or at least...
Monday, 25 January 2021 - 23:09
Looking for help with i2c(TWI).
Sorry second link was meant to be this https://www.raphnet.net/electron...   Yeah I have a few traces I can upload (will attach to this post). I added a scan that shows when...
Saturday, 23 January 2021 - 22:07
Looking for help with i2c(TWI).
Sorry if that was unclear somehow but I have a scope... OP says "I see on the scope that the master sends its address and data constantly. "   Also here is where no pull ups...
Saturday, 23 January 2021 - 14:46
spi always recived the same data I send out.
Crap, break out board had a bad via. Never was connected to the MCU.
Tuesday, 5 January 2021 - 01:40
spi always recived the same data I send out.
Perhaps I'm wrong about the returned data, it appears to always be 0xff. I was sure it was echoing the data sent in... Still confused, but possibly easier this to track down. This...
Tuesday, 5 January 2021 - 00:24
Need some help understanding how to move the interrupt vector
Will that change the interaction time for that first falling edge?  
Saturday, 26 December 2020 - 16:37
Need some help understanding how to move the interrupt vector
I wrote that pieces in asm ?     Did you mean the surrounding code? void Poll(void) { unsigned char _low_state_portd_first =0xF3;//prep bits unsigned char...
Saturday, 26 December 2020 - 14:38
Need some help understanding how to move the interrupt vector
After a lot of observations with the real hardware using a scope, it turns out there is only a concern at the first falling edge.  And it is only for some cases not all). The...
Friday, 25 December 2020 - 21:44
Need some help understanding how to move the interrupt vector
All of the tweaks to this point have helped there is just the matter of the first falling edge that I think I can fix to sync the entire loop all together.   Here is the code...
Tuesday, 22 December 2020 - 22:09

Pages