Type in the full discussion title or a part of it.
Discussion Title Created date
Looking for help with i2c(TWI).
I have a good grasp on how i2c works but need help with detail to troubleshoot my application. I love hardware base protocols when they work but when they don't it's a pain to fix...
Thursday, 21 January 2021 - 22:13
spi always recived the same data I send out.
I wrote some simple SPI slave code a while back that has worked fine for some time. I use an atmega32u4 and have it wired to a harness. This Harness connects to a master SPI...
Tuesday, 5 January 2021 - 00:07
How can I catch a chip in if defined?
using AVR studio 7.   I thought I had this working but its not, I need to do the below here but it simple is not working.  How does the __AVR_xxxxxxxxxxx__ get set. My...
Monday, 21 December 2020 - 23:45
Need some help understanding how to move the interrupt vector
I'm trying to use this approach. https://www.raphnet.net/programm... If I use the normal ISR I'm good   Working method. ISR (INT2_vect ) { PORTF |= 0x01; PORTF &= ~0x01...
Saturday, 19 December 2020 - 20:10
What exactly does "AVR I/O clock to be present" mean?
I want to use the PE6 int6 on my atmega32u4 but read that the AVR I/O clock needs to be present. I always thought that meant the internal clock, thus implying its presence is...
Wednesday, 16 December 2020 - 22:23
atmega32u2 dooes not leave bootloader
I have a project I created on a  atmega32u2 breakout board. Works just fine so I'm now moving to my own board. I based the schematic/board off the same design but after I...
Saturday, 5 December 2020 - 21:29
Atmega32u4 16 to 20 or greater.
I have hit a brick wall with my current project and I have no choice but to up my clock from the standard 16MHz. So just brain storing here.   1) Adjusting my code, ill have...
Saturday, 28 November 2020 - 13:24
help with ASM pin change.
I'm not sure the best way to speed this up but I need to make these a couple hundred ns faster. I'm currently using an ATMEGA32u4 with a 16MHz clock. If there is no other way, ill...
Tuesday, 17 November 2020 - 17:18
atmega32u4 partial functionality from port D pullups
I'm using an atmega32u4  and when setting my PORTD (all bits)  to out and Low I'm not seeing the analyzer react on all pins.  I do not have an external pull ups. If...
Tuesday, 20 October 2020 - 18:28
timer1 and 2 are not working the same.
Using an ATMEGA328, I have two timers and only using them for back ground counters, no interrupts.     Timer 1 my init is TCCR1B = (1<<CS12); using it like so if(...
Tuesday, 1 September 2020 - 17:05
My pin detection change from first to second run
I have a project on an old atmega328 (12MHz) that I use a wile loop to detect a pin change. I'm not sure the pinchange interrupt would help or be my issue here but for debugging I...
Wednesday, 19 August 2020 - 14:57
applied 5 volts to spark fun nrf24+
I ordered 2 sparkfun boards and could not figure out why one didnt work until I saw it was wired to 5 volts. (damn).. I have ordered my replacemens but was wondering if anyone...
Thursday, 16 July 2020 - 15:39

Pages