Post Created date
Compile errors in AVR Studio 4 while building project
Hi guys, I am facing some problems with my AVR Studio. I think I accidently clicked some fuse settings while programming the AVR. I get the following message while programming the...
Sunday, 4 November 2007 - 12:42
[TUT] [C] Newbie's Guide to AVR Timers
Hi Dean, Well I haven't changed the ATmega16's fuse settings as I don't know how. Earlier I was just experimenting assuming that it was running @ 16MHz.But i changed the code as...
Saturday, 3 November 2007 - 11:55
[TUT] [C] Newbie's Guide to AVR Timers
Hi guys, Actually I realised my mistake now. My actual clock source which comes from a 16 MHz crystal was running at 1 MHz speed. I found this out from the following extract in...
Saturday, 3 November 2007 - 10:56
[TUT] [C] Newbie's Guide to AVR Timers
Hi Johan, I tried your suggestion, but still couldn't get it working. I tried both the statements without much luck :( DDRB |= (1<<0); DDRB |= _BV(1<<0); I am...
Saturday, 3 November 2007 - 10:19
[TUT] [C] Newbie's Guide to AVR Timers
Hi Dean, After reading your article, I decided to try it out with my ATmega16 which runs on a 16 MHz clock source. I decided to go with the CTC mode to toggle an LED at 1 Hz. My...
Friday, 2 November 2007 - 19:21
[TUT] [C] Newbie's Guide to AVR Timers
Hi Dean, After reading your article, I decided to try it out with my ATmega16 which runs on a 16 MHz clock source. I decided to go with the CTC mode to toggle an LED at 1 Hz. My...
Friday, 2 November 2007 - 18:53
Compile errors in AVR Studio 4 while building project
Hi, Thanks for your input...I figured that out.Now I have modified the code as below and it compiles fine. ldi r16, low(RAMEND) out SPL, r16 This gives the low byte (8-bits) of...
Saturday, 27 October 2007 - 06:48
Compile errors in AVR Studio 4 while building project
Hi, There is another project I am working on simultaneously as listed in the link below: http://www.geocities.com/digitan... I am using the Atmega16 microcontroller with a 16 Mhz...
Thursday, 25 October 2007 - 18:16
Compile errors in AVR Studio 4 while building project
Hi, Can anybody please help me with this? I haven't been able to proceed further due to these errors. Thanks, Sumair
Thursday, 25 October 2007 - 17:43
Compile errors in AVR Studio 4 while building project
Sorry forgot to add the makefile ############################################################################### # Makefile for the project Tether...
Monday, 22 October 2007 - 17:10
Compile errors in AVR Studio 4 while building project
Yes I have that header file included on top. In my makefile I have defined my MCU as Atmega16, so it should pick up the file io/iom16.h right? Please see my makefile attached....
Monday, 22 October 2007 - 16:58
Compile errors in AVR Studio 4 while building project
Yes I tried that too, but still get the same errors. This are the definitions: #define DDRB_INIT 0xF9 #define PORTB_INIT 0xFF #define DDRD_INIT 0xFF #define PORTD_INIT 0x01...
Monday, 22 October 2007 - 16:19

Pages