Post Created date
Problem with Serial Communication
Hi guys, I finally figured out the problem. I had wired the circuit wrongly for the MAX232. After pin 8 I started counting the pin 9 on the top right hand side of the PDIP package...
Saturday, 17 November 2012 - 10:27
Problem with Serial Communication
Quote:Also the 10uF capacitor on AVR pin 9 (reset, who knows) is overkill. Since your schematic is missing pin names, I won't start analyzing pin names to know if they are...
Saturday, 17 November 2012 - 06:30
Problem with Serial Communication
Quote:Do a loop test. 1. Short pins 2,3 on DB9 (MAX232 disconnected). The terminal should echo typed characters. I tried this and the terminal echoes back the characters. Quote:2...
Saturday, 17 November 2012 - 06:23
Problem with Serial Communication
I'm using 1 microfarad/63 volts capacitors for the MAX232N and for the decoupling capacitor I'm using a 10 microfarad/63 volts capacitor.
Friday, 16 November 2012 - 17:12
Problem with Serial Communication
Quote:The capacitor at pin 2 of the MAX is reversed. PS: And where are the decoupling capacitors? I reversed the capacitor polarity at pin 2 and also added a decoupling capacitor...
Friday, 16 November 2012 - 17:10
Problem with Serial Communication
Oops my bad, i think there was some problem with the attachments. I'm re-sending them again.
Friday, 16 November 2012 - 13:09
Problem with Serial Communication
I am using MAX232N chip and i checked the wiring diagram in the datasheet and it matches with the circuit diagram provided earlier. I have attached the picture taken from the...
Friday, 16 November 2012 - 09:22
Servos twitching at one end
I determined the values of MIN_SERVO as 500 and MAX_SERVO as 2500 with a little experimentation.
Tuesday, 24 July 2012 - 13:14
Servos twitching at one end
Hi, Thanks for all your replies. I found out what the problem was and have fixed it. The formula used to calculate the value of ICR1 was wrong. After using the correct formula the...
Tuesday, 24 July 2012 - 13:12
Servos twitching at one end
In one of the forum posts i had seen that you can verify the servo signal between 0.6 ms and 2.4 ms which is why i had specified these values. I guess i need to check my servo...
Thursday, 19 July 2012 - 10:34
Servos twitching at one end
I forgot to mention the different servo positions which i have placed in an array. const uint16_t servo_positions[17] = {150, 178, 206, 235, 263, 291, 319, 347, 375, 404, 431,...
Tuesday, 17 July 2012 - 07:03
Current consumption using a lead acid battery
Hi Jepael, You were right, the 7805 does get hot after 5-10 mins of continuous robot operation. After googling I found out the reasoning as you mentioned above. The difference...
Monday, 25 June 2012 - 06:16

Pages