Type in the full discussion title or a part of it.
Discussion Title Created date
PWM using timer 0 of ATmega16
Hi, I am developing a robot arm consisting of 5 servo motors using an ATmega16 and interfacing it via USART. the USART is configured to run at 9600 kbps and the ATmega16 is...
Tuesday, 25 December 2012 - 09:26
Output contents of OCR1A and OCR1B to terminal using USART
Hi, I would like to know if it is possible to display the contents of OCR1A to a terminal using serial communication once I have the functions usart_putstring(OCR1A) as shown...
Tuesday, 27 November 2012 - 11:42
Problem with Serial Communication
Hi, I am trying to do a simple serial communication interface between ATmega16 and my laptop. Since my laptop does not have a serial port, I am using a Bafo USB-serial adapter...
Friday, 16 November 2012 - 06:20
Servos twitching at one end
Hi, I am working on a project to make a robot arm. I have started testing by driving 2 servos one for the shoulder movement and the other for the elbow. I am controlling the...
Tuesday, 17 July 2012 - 07:00
Current consumption using a lead acid battery
Hi, I have an STK500 based AVR development board that has a 7805 voltage regulator, 4 LEDs for debugging, and an L293D motor driver chip in addition to the ATmega16 chip. I have...
Friday, 15 June 2012 - 11:03
Breaking out of a loop
Hi, I am working on a mini robot project where i am trying to drive servos using the PS2 controller. I have defined the different servo positions as an array as shown below:...
Thursday, 26 January 2012 - 18:22
Interfacing a USB joystick to AVR
Hi, I want to interface my USB joystick to AVR Atmega16, so was looking for some starter tips. I want to be able to read the joystick positions and the button states using the AVR...
Tuesday, 23 August 2011 - 05:40
Motors are not running properly
Hi, I am running 2 motors simultaneously using ATmega16 through a L-293D H-Bridge motor driver. The motors were working fine for some time, but after a while they have stopped. I...
Thursday, 17 June 2010 - 09:57
Testing internal RC oscillator frequency
Hi, I am running some application on my ATmega16 on 8 MHz internal RC oscillator. Just to be sure that the clock frequency is right I wrote a test program to toggle an LED at 1 Hz...
Wednesday, 2 June 2010 - 09:41
Can Logic Analyzer be used to measure clock & PWM Signal
Hi, This may be a dumb question, but I want my doubt to be clarified. I am planning on buying a Logic Analyzer either from Saleae Logic or USBee. Can a logic analyzer measure the...
Monday, 17 May 2010 - 05:45
Servo Motor Control Using PWM
Hi, I am trying to run a servo control using PWM in phase and frequency correct mode.After programming my AVR (Atmega16), when i run it, the servo only twitches without actually...
Monday, 9 June 2008 - 18:49
ISP Mode Error in AVR Studio version 4.13
Hi guys, I am facing some problems with my AVR Studio. I think I accidently clicked some fuse settings while programming the AVR. I get the following message while programming the...
Sunday, 4 November 2007 - 16:41

Pages