Type in the full discussion title or a part of it.
Discussion Title Created date
[ASM] DOGM132x-5 over SPI on ATmega8820AU
Hi guys! I'm not sure if I'm having problems with SPI in general or "just" with the Display (DOGM132x-5) - either way, it doesn't display anything at all. I'm using the ATmega...
Monday, 6 December 2010 - 22:29
Resolved: [ASM] tiny13 ADC not triggering on timer overflow
Hi there! I'm trying to get the ADC on an ATtiny13 (@1MHz) working with the timer triggering a conversion every 1/25 sec (i.e. 25 conversions per second). What I have: Timer0 in...
Saturday, 6 February 2010 - 17:57
Power and data on the same line - easy?
Hi guys! I'm working on a microcontroller project for university here, kind of a small p2p bus system on AVRs. The problem I'm currently facing is I'd like to use as little wires...
Tuesday, 4 November 2008 - 01:13
OT: 666 pages in this forum...
Hi guys! We have 666 pages of threads in the AVR forum as of now (which is 6:18pm european summer time which should be 5:18pm GMT). What does this mean for the forum, what for...
Tuesday, 4 September 2007 - 17:09
home automation bus
Hi guys! I stopped my bus project and fell back to planning it because I got some great input here making me believe my approach was far from good although it did work. This...
Sunday, 26 August 2007 - 08:55
Database in EEPROM, with ASM
Hi guys! I'm currently facing the problem to create a flexible database within EEPROM memory that should not waste any space because there isn't much available. Basically, I need...
Thursday, 16 August 2007 - 05:26
drive Luxeon Emitter with resistor for testing?
Hi guys! The Luxeon emitters / stars are my choice for lighting, now I'll have to build a test circuit with them. Is it possible without destroying them to limit current with a...
Tuesday, 7 August 2007 - 06:50
which ext. memory for storing ~1MB of raw data?
Hi guys! For my bus system, I'm currently developing (planning) the master module and noticed there is no AVR with enough memory for my needs. I have to store at least 3-5 bytes...
Wednesday, 1 August 2007 - 06:01
ATmega16: timer1: fast PWM not working
Hi guys! I have -guess what?- yet another problem with my ATmega16. I'm trying to use timer1 (the 16 bit timer) as 2-channel fast PWM generator. ldi acc, 0b00000001 out TCCR1A,...
Friday, 27 July 2007 - 09:22
PWM strangeness on ATmega16
Hello there! Today, I -again- tried to get fast PWM working on my ATmega16. Only real hardware as the simulator now seems to repeatedly random-jump into all ISRs in all AVR...
Friday, 27 July 2007 - 06:28
ATmega16: Interrupt firing without Flag being set
The newbie again... ATmega16, Assembler. Are there any common reasons for an interrupt (ext. interrupts 0 and 1) to fire without the corresponding interrupt request flag being set...
Wednesday, 25 July 2007 - 13:06
ASM: EEPROM always reads 0xFF
Hi again! I tried reading stored values from EEPROM and putting them into SRAM on my ATmega16. SRAM isn't a problem, but EEPROM is. I followed a tutorial about reading from EEPROM...
Wednesday, 25 July 2007 - 07:11

Pages