Type in the full discussion title or a part of it.
Discussion Title Created date
Wrong datasheet linked to ATmega164
I just thought I would point out that the datasheet linked on the page for the ATmega164 is linked to doc2593.pdf, which is the datasheet for the ATmega644/V.
Friday, 5 June 2009 - 02:10
Recognizing entire string sent over serial, not just a byte.
I am writing a program for the AVR that communicates with a Python program running on the computer. The Python program sends strings ending in a ";" to the AVR over serial, and...
Friday, 17 October 2008 - 01:14
*def.inc files (version 1)
I am currently trying to get amforth running on my atmega644. I have gotten really far and I hit a snag. I need version 1 of the m644def.inc file. I can only find version 2. Could...
Monday, 30 June 2008 - 00:17
AVR-GCC Not Compiling on Linux(Gentoo)
Hi, Im compiling AVR-GCC on my Gentoo box so I can start doing stuff with AVR's again, but its having compile errors. Actually, AVR-GCC went fine, its libc. Im using this guide/...
Sunday, 15 June 2008 - 18:10
LM741 OP AMP Not Working
Hello everyone, I am doing a project with Accelerometers, useing the ADXL202EB, which is an evaluation board. It outputs a 50% duty cycle square wave with no acceleration, and...
Thursday, 27 March 2008 - 02:35
Interfacing PS/2 Mouse to AVR
Hello everyone, Right now I am trying to interface a PS/2 mouse to my ATmega32 so I can get direction and click data. I have read a bit about the PS/2 protocol, and have figured...
Wednesday, 12 March 2008 - 23:59
ATmega32 will only send one character over serial?
Hello everyone, I have been having problems with the serial again on my ATmega32. It will send data fine, but only one character of it. I have tried several different things,...
Tuesday, 11 March 2008 - 04:18
ATmega32 not recognized by AVR Studio.
My shipment of stuff from Digi-Key arrived today, and I got some ATmega32's with it. The data sheets appear to show that they are pin compatible with the ATmega16 that I have...
Monday, 18 February 2008 - 01:55
Fried Pins?
I have been experimenting with my AVR and just tried to use the USART communication, however it would not work. I think tried to run blinkLED on those pins, and they just do not...
Sunday, 17 February 2008 - 06:49
sprintf appears to restart main
Hello Again, I fixed my previous error and got the array to return with a pointer, but now I have another dilemma. When I call sprintf within main it restarts! I know this...
Saturday, 5 January 2008 - 22:53
Returning an Array?
In my C program I am using a stepper motor with a rangefinder mounted on it to map out the room where the robot it. I am using an array to store all of the distances. Ideally I...
Saturday, 5 January 2008 - 06:54
PWM Timing Question
I am using OC1A and OC1B to control servos. I have the uptime correct, but the pulse is off too long. It is off for 19ms when it should be off for 16ms. How do I change the...
Saturday, 29 December 2007 - 18:36

Pages