Post Created date
C code meets assembler - And falls down
I originally wrote it with while ((((volatile uint8_t) PINE) & 0x40) == 0x00) {} // Until READY goes high Count[i] = ((volatile uint8_t) PINB); // When gone high, But...
Monday, 4 April 2011 - 00:28
Assembler: Where are the labels ?
If it has opcodes, it's got assembler. The mnemonics may be oddball, but it's got assembler. S.
Wednesday, 30 March 2011 - 06:12
Assembler: Where are the labels ?
Papabravo wrote:The AVR32 has no "native" assembler ... Hell we even built our on CPUs from 74181 ALU slices and there was nobody to write assemblers for us, ya bunch of whinners...
Sunday, 27 March 2011 - 07:54
Assembler: Where are the labels ?
Assembler Forever!! :)
Wednesday, 23 March 2011 - 23:13
Assembler: Where are the labels ?
Ohdear. That's a deal-breaker for me. I've many lengthy programs in assembler, and inability to find labels would make working on them a nightmare. Think I'll stick with Studio...
Wednesday, 23 March 2011 - 04:04
LUFA and C and me and decrementing For loops (bug?)
PS - It works fine now, although I've still got off-by-one errors and i < 0 is its own kettle o' fish when i is an unsigned int... :)
Friday, 11 March 2011 - 01:13
LUFA and C and me and decrementing For loops (bug?)
I have got it. It loops *while* the condition is true, not *until* the condition is true. Thanks to both o' ya!
Friday, 11 March 2011 - 01:11
LUFA and C and me and decrementing For loops (bug?)
Ahh. I may have gotten it... My bad?
Friday, 11 March 2011 - 00:26
LUFA and C and me and decrementing For loops (bug?)
It's "less than" 10 in the code that doesn't work. i is supposed to be counting down - Yet never gets there? I think your loop would execute once. S.
Friday, 11 March 2011 - 00:24
In-system programming daisychain?
Hi All. Quote: I wonder if you connected the output of the programmer to all devices but only had the return signal from one of them connected back whether that would work? So...
Wednesday, 28 April 2010 - 23:55
Port A and external clocks on tiny2313
Hi David, Yeah, you are correct in that trying it would have been simpler, but I managed to smoke my STK500 awhile back through incompatible power jumper settings. I was about to...
Friday, 19 February 2010 - 16:02
Port A and external clocks on tiny2313
PS - And I still can't find it mentioned under 'External Clock'. It's mentioned under 'Alternate Port Functions' again. S.
Friday, 19 February 2010 - 01:02

Pages