Post Created date
ATMEGA88 and ESP-01: Problem running outside STK500
I was wondering about that RESET pin, if it should be pulled high or left floating. I've sort of tried either. Now it's pulled high (through 10k). And I connected the grounds....
Saturday, 7 November 2020 - 18:50
ATMEGA88 and ESP-01: Problem running outside STK500
I'll try to connect the grounds. I'm checking that the AVR is sending by connecting a wire to an FTDI to USB chip, so I can see what's going in (or out) in a terminal.
Saturday, 7 November 2020 - 12:40
ATMEGA88 and ESP-01: Problem running outside STK500
Thanks a lot for your help! Status now, after the various adjustments, is that the ESP is no longer spewing bytes :) I also can see the AVR is sending the AT commands as it...
Saturday, 7 November 2020 - 12:00
ATMEGA88 and ESP-01: Problem running outside STK500
I see... How important is the actual capacitance?  Can I use a 10microF, do you think? I'm waiting for more components :D
Saturday, 7 November 2020 - 11:37
ATMEGA88 and ESP-01: Problem running outside STK500
Note the big C1 and C2 caps on there...
Saturday, 7 November 2020 - 11:29
ATMEGA88 and ESP-01: Problem running outside STK500
Sorry, but did you read my full text? I appreciate that I do need a cap for the wall wart, but my question was: Can't I assume there IS a cap on the 5V USB power supply -- simply...
Saturday, 7 November 2020 - 11:29
ATMEGA88 and ESP-01: Problem running outside STK500
But still just garbage data :( Maybe something is starting to stabilize. Rookie question: Is it a big significance whether I use the 5V GND or the 3.3V GND? I mean, for the...
Saturday, 7 November 2020 - 11:06
ATMEGA88 and ESP-01: Problem running outside STK500
Thanks for the advice! I've set up a 10k/20k voltage divider between the AVR and the ESP. I've also grounded the "IO0" pin, as this seems to be done in the PDF you linked to....
Saturday, 7 November 2020 - 11:04
ATMEGA88 and ESP-01: Problem running outside STK500
How can I reduce the voltage on the data line from the AVR to the ESP, from 5 to 3.3V? Can I simply use a resistor between PD1 and URXD?
Saturday, 7 November 2020 - 09:01
ATMEGA88 and ESP-01: Problem running outside STK500
awneil wrote: Couldn't the  ESP8266  do the whole thing itself - isn't the  ATMEGA88  a bit redundant?     Well, I'm not really sure. I have been...
Friday, 6 November 2020 - 23:45
ATMEGA88 and ESP-01: Problem running outside STK500
Thanks for the quick response! Could you please explain where these bypass capacitors should be placed?
Friday, 6 November 2020 - 23:40
USART configuration for ATMEGA88
OK, finally, this seems to have converged to something stable :D Setting high-freq crystal, as below, does not brick the AVR and the program seems to run as intended!...
Sunday, 29 December 2019 - 10:23

Pages