Type in the full discussion title or a part of it.
Discussion Title Created date
Can't enter programming mode after setting external Xtal
I have wrote and debug my code while running the internal RC. Now I want to test the UART so I set the fuses for the external Xtal (4MHz). Now the code keeps running but I can not...
Friday, 23 June 2017 - 12:22
How to include header & source files in a sub-dir?
I want to include header files and the related source files.   I've created a folder where the main.c is and dropped all the related files inside. Inside project properties,...
Friday, 16 June 2017 - 18:08
SRAM with multiplexed data & address lines?
I am looking for some external RAM I can hook up to an AVR using few lines as possible (less than 15). Seems like all the "new" stuff have dedicated pins for the different buses....
Wednesday, 26 April 2017 - 16:14
1:1 transformer hookup & termination
I want to use a couple of 1:1 isolation transformers in order to enable an audio signal to be routed to one of two audio amps or both of them together and eliminate ground loops....
Friday, 3 March 2017 - 23:32
How to tell if DFLL is working?
I want to enable run-time calibration of the 2MHz clock. Since that clock is the default for the ATxmega64A3U it seem I only need to run the following code: OSC_CTRL |=...
Wednesday, 22 February 2017 - 22:12
AVR draws more current when sleeping?
I have a low power project going on and I have decided to look into the exact current consumption figures of the circuit. Most of the time the circuit is just sitting there doing...
Wednesday, 22 February 2017 - 20:27
Clock change not working right (div)
I want to working with the 32MHz clock divided by 8 = 4MHz and pass it through pre-scallers B & C. Here is my code: void CLK_Config(volatile CLK_t *clk, volatile OSC_t *osc...
Sunday, 19 February 2017 - 20:26
xmega clock can't reach stability?
When debugging I've noticed the code get stuck in the while loop. static inline void osc_wait_ready(uint8_t id) { while (!osc_is_ready(id)) { /* Do nothing */ } }Xtal is 4MHz...
Sunday, 19 February 2017 - 12:16
MIDI output circuit does not go "low" enough
I've build a circuit that feeds from the power of the MIDI current loop, it should output MIDI as well. The output circuit is just the UART output into a 10 Ohm resistor and the...
Friday, 17 February 2017 - 20:00
Error compiling debug project (only)
When I try to compile the "release" build there is no problem, however when trying to build the "debug" version I get the followings errors:   Severity    Code...
Wednesday, 15 February 2017 - 16:10
What is the problem with the linking during the build?
I want to add Peter Fleury's I2C library to a project.   The unzipped files are located in a folder inside the project folder, this is in order to keep things more neatly...
Saturday, 7 January 2017 - 20:08
MOSFETs for switching AC?
I want to be able to conduct / disconnect an AC signal between input & output. For this purpose I would like to use MOSFETs that I have around for cheap like the 2N7002 or the...
Tuesday, 3 January 2017 - 22:03

Pages