Post Created date
New xmega Bootloader (App Note AVR1605) - Port to GCC
Has anyone been able to program Xmega fuse bits with this bootloader? I have not been able to read or write fuse bits with avrdude 5.6 and ATXMega128a3 with my version of the...
Thursday, 3 December 2009 - 18:33
problem with JTAGICE mkii
I replaced my JTAG ICE mkii (rev A) with a new one from Digikey (rev B presumably) and AVR Studio 4.17 is now running smoothly.
Monday, 16 November 2009 - 15:16
Double interrupts on XMega simulator?
I tried your code through AVRstudio 4.17 with "simulator2" and initially all the interrupt flags for the compare (CCA, CCB, etc) and overflow are all set initially. After the...
Friday, 13 November 2009 - 15:11
New xmega Bootloader (App Note AVR1605) - Port to GCC
Okay. So I got the bootloader to work on the 128A3 as well. But there was a serious problem with the chip. It appears the PORTD USART is not working. Transmit is fine but the...
Saturday, 7 November 2009 - 13:35
New xmega Bootloader (App Note AVR1605) - Port to GCC
Now that I've read the errata I'm surprised it works too! I loaded a simple test program with the bootloader that was only 600bytes but it loaded and verified without error and...
Thursday, 5 November 2009 - 13:14
New xmega Bootloader (App Note AVR1605) - Port to GCC
I just got damien_d's port of the AVR1605 note to avr-gcc to work on the bostonandroid.com Xmega64a3 board. Some minor mods for page sizes and num pages. I also modified the...
Thursday, 5 November 2009 - 00:11
New xmega Bootloader (App Note AVR1605) - Port to GCC
Is there any chance they will release a new binary to go with the application note? I want to try to get a AVRosp compatible bootloader running on a new version of this board:...
Thursday, 15 October 2009 - 16:35
problem with JTAGICE mkii
I've actually had the same problem. AVR studio 4.17 & JTAGICE mkII don't seem to work together. IAR workbench 4.20 seems to work fine though. Atmel has no update for AVR...
Thursday, 8 October 2009 - 21:13
XMEGA and DAC
Got it! Thanks ganzziani. I neglected to update DMA trigger source to DACB instead of A. DMA.CH0.TRIGSRC= 0x25; // DACB CH0 is trigger source Now I need to figure out how...
Tuesday, 6 October 2009 - 21:08
XMEGA and DAC
ganzziani wrote:Today I have successfully implemented an arbitrary waveform generator on my XMultiKit XMEGA project :D Using the DMA and event system hooked to a timer, the...
Tuesday, 6 October 2009 - 14:21
xmega Development Board
Sure. Here's a screen shot of the Eagle Layout. I'm thinking of spinning a second smaller board with one of the TQFP-44 parts. Leaning towards the Xmega64a4.
Tuesday, 29 September 2009 - 11:46
xmega Development Board
I got tired of waiting for someone to release a simple XMega board to try out the new chip. So I made one myself; basically just landing for the atxmega64a3 TQFP-64, 3.3V...
Monday, 28 September 2009 - 13:02

Pages